Chapter 13. Logging and Monitoring in OpenStack Operations Guide

Bug #1457768 reported by N Dillon
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openstack-manuals
Won't Fix
Wishlist
Unassigned

Bug Description

Process monitoring recommendations - the Process Monitoring section mentions the nova-api and nova-compute processes, but does not mention any others (only that "at least one nova-compute" process will be running if the attestation recommended is implemented.

The exact processes should be called out, as well as the number - or how to determine how many should be running (for example, the nova.conf file may limit the number per host, or the filters, or there will be one per vm on the host, or...)
-----------------------------------
Built: 2015-05-16T15:22:32 00:00
git SHA: 253e05b6a76004212781d7c24b0b7d7f2c2377e7
URL: http://docs.openstack.org/openstack-ops/content/logging_monitoring.html
source File: file:/home/jenkins/workspace/operations-guide-tox-doc-publishdocs/doc/openstack-ops/ch_ops_log_monitor.xml
xml:id: logging_monitoring

Tags: ops-guide
Tom Fifield (fifieldt)
Changed in openstack-manuals:
milestone: none → liberty
importance: Undecided → Wishlist
status: New → Confirmed
tags: added: ops-guide
Changed in openstack-manuals:
milestone: liberty → mitaka
Changed in openstack-manuals:
milestone: mitaka → newton
Shaun OMeara (shaunom)
Changed in openstack-manuals:
assignee: nobody → Shaun OMeara (shaunom)
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to openstack-manuals (master)

Fix proposed to branch: master
Review: https://review.openstack.org/356413

Changed in openstack-manuals:
status: Confirmed → In Progress
Changed in openstack-manuals:
assignee: Shaun OMeara (shaunom) → Darren Chan (dazzachan)
Changed in openstack-manuals:
assignee: Darren Chan (dazzachan) → KATO Tomoyuki (kato-tomoyuki)
Changed in openstack-manuals:
assignee: KATO Tomoyuki (kato-tomoyuki) → Darren Chan (dazzachan)
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to openstack-manuals (master)

Reviewed: https://review.openstack.org/356413
Committed: https://git.openstack.org/cgit/openstack/openstack-manuals/commit/?id=f4b046bbf4d1c19cfc840d26f5468b622847a736
Submitter: Jenkins
Branch: master

commit f4b046bbf4d1c19cfc840d26f5468b622847a736
Author: Shaun O Meara <email address hidden>
Date: Wed Aug 17 13:57:00 2016 +0200

    [ops-guide] Openstack process

    1. Added openstack process
    2. Minor restructure to seperate openstack components from 3rd
       party software.

    Change-Id: If2fd671f1407f9b7fe06aab4266f43280d50b80f
    Closes-bug: 1457768

Changed in openstack-manuals:
status: In Progress → Fix Released
Revision history for this message
N Dillon (sicarie) wrote :

The addition does not address this bug, and was made to the ops-guide, not sec-guide

Changed in openstack-manuals:
assignee: Darren Chan (dazzachan) → nobody
status: Fix Released → Confirmed
milestone: newton → none
Revision history for this message
Alexandra Settle (alexandra-settle) wrote :

Nathaniel - this bug was targeted to the operations guide (see tags, and original reference points) as you originally reported.

See here: URL: http://docs.openstack.org/openstack-ops/content/logging_monitoring.html

Why did you reopen this for the sec-guide? Could you please clarify what this needs if it is indeed required by the sec guide and not the ops guide?

Changed in openstack-manuals:
status: Confirmed → Incomplete
Revision history for this message
N Dillon (sicarie) wrote :

I'm not sure why I mentioned the sec-guide in there, however my original bug was that only a select few items were called out generally. Re-opening was due to:

1) My main issue is that the two examples I see are for disk utilization and plugins and only 5 total general categories are called out (Disk usage, Server load, Memory usage, Network I/O, Available vCPUs) - are these the only things that should be monitored on a nova deployment? Is warning at 80% utilization and critical at 90 applicable across *all* deployments? Or is there a way we can enable a deployer to determine what their threshold should be based on their use-case?

2) The examples are in Nagios - this issue was recently brought up in the sec-guide: do we attest to non-OpenStack ecosystem applications? Should this be referenced in its own section?

3) Object storage links are to Mirantis docs - are these not addressed in the OpenStack documentation? It's fine if they're not, I just want to make sure that is being considered (and we should probably have doc bugs opened on them for that project in that case).

Full disclosure: I'm a huge Nagios fan, I think it should be in there, but I also think that getting coverage on *what* would be more useful, and we need to make sure the Foundation agrees with the position of including/not the outside applications (sec-guide dev has slowed significantly due to this ambiguity). Had I not been on leave, I would have recommended this be merged as a partial-bug until we get the rest of the "what" set up. Apologies for the lateness and lack of clarity!

Revision history for this message
Alexandra Settle (alexandra-settle) wrote :

Nathaniel - I understand and see your points. I'd like to move this to the mailing list however. Would you mind if we brought this conversation into the open?

Thanks,

Alex

Changed in openstack-manuals:
status: Incomplete → New
Changed in openstack-manuals:
status: New → Confirmed
Revision history for this message
N Dillon (sicarie) wrote :

Absolutely!

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/openstack-manuals 15.0.0

This issue was fixed in the openstack/openstack-manuals 15.0.0 release.

Lana (loquacity)
Changed in openstack-manuals:
status: Confirmed → In Progress
Changed in openstack-manuals:
status: In Progress → Confirmed
Changed in openstack-manuals:
status: Confirmed → Invalid
status: Invalid → Won't Fix
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers