Cloud Administrator Guide claims that users should start multiple L3 agents to serve multiple external networks

Bug #1380585 reported by Ihar Hrachyshka on 2014-10-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openstack-manuals
High
Darren Chan

Bug Description

Quoting http://docs.openstack.org/admin-guide-cloud/content/adv_cfg_l3_agent_multi_floatip.html

"Because you can associate each L3 agent with, at most, one external network, you must invoke multiple L3 agents to define multiple floating IP pools."

This is wrong since https://review.openstack.org/#/c/59359/ was merged (included in all branches since Havana)

Tom Fifield (fifieldt) wrote :

Thanks Ihar!

Changed in openstack-manuals:
milestone: none → juno
status: New → Confirmed
importance: Undecided → High
tags: added: neutron
Darren Chan (dazzachan) on 2014-10-17
Changed in openstack-manuals:
assignee: nobody → Darren Chan (dazzachan)
Darren Chan (dazzachan) wrote :

I'll look at this since I was trying to address this issue in https://bugs.launchpad.net/openstack-manuals/+bug/1317690 for havana documentation.

Fix proposed to branch: master
Review: https://review.openstack.org/129504

Changed in openstack-manuals:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/129504
Committed: https://git.openstack.org/cgit/openstack/openstack-manuals/commit/?id=3488166f6308bc4b2cd0f3085e5750cf7977e75e
Submitter: Jenkins
Branch: master

commit 3488166f6308bc4b2cd0f3085e5750cf7977e75e
Author: darrenchan <email address hidden>
Date: Mon Oct 20 13:25:51 2014 +1100

    Edited multiple floating IP pools in Cloud Administrator Guide

    1. Removed steps to configure multiple L3 agents for multiple external networks
    2. Added configuration of a L3 agent to handle multiple external networks.

    Change-Id: I7ff2f01d40a84a6c7ebd06a0b3fbdd527cd12c9d
    backport: icehouse
    Closes-Bug: #1380585

Changed in openstack-manuals:
status: In Progress → Fix Released

This issue was fixed in the openstack/openstack-manuals 15.0.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers