Add admin tenant name to nova notifier

Bug #1378148 reported by OpenStack Infra on 2014-10-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openstack-manuals
High
Tom Fifield

Bug Description

https://review.openstack.org/103978
commit cf92bbead9b25ee40a3336bd76110b3733a4f7ee
Author: Erik Colnick <email address hidden>
Date: Wed Jun 18 11:31:52 2014 -0600

    Add admin tenant name to nova notifier

    This change introduces the ability to use the nova admin
    tenant name with the nova notifier in place of the nova
    admin tenant id which may not be available when the neutron
    service is being configured as is the case with tripleo
    installations where the neutron service is configured and
    started before the nova admin tenant has been configured in
    keystone and thus does not have a known id.

    DocImpact
    Introduces the nova_admin_tenant_name configuration entry as
    an optional configurable value in neutron.conf. If the
    nova_admin_tenant_name is configured and the nova_admin_tenanat_id
    is not configured, a performance impact may be seen because
    keystone will become involved in communication between neutron
    and nova.

    Change-Id: I33701d4dc9bf61595e44a49050c405ebca779091
    Closes-Bug: #1331566

Tom Fifield (fifieldt) on 2014-10-10
tags: added: autogenerate-config-docs
Changed in openstack-manuals:
milestone: none → juno
importance: Undecided → High
status: New → Triaged
Matt Kassawara (ionosphere80) wrote :

Does not impact installation guide.

Changed in openstack-manuals:
assignee: nobody → Marios Andreou (marios-b)

Fix proposed to branch: master
Review: https://review.openstack.org/132233

Changed in openstack-manuals:
status: Triaged → In Progress

Change abandoned by Marios Andreou (<email address hidden>) on branch: master
Review: https://review.openstack.org/132233
Reason: ok so apparently i need to learn a lot about the docs :)

Changed in openstack-manuals:
assignee: Marios Andreou (marios-b) → nobody
Tom Fifield (fifieldt) on 2014-11-19
Changed in openstack-manuals:
status: In Progress → Confirmed
Tom Fifield (fifieldt) wrote :

This was picked up by the recent autogenerate-config-doc run.

Changed in openstack-manuals:
assignee: nobody → Tom Fifield (fifieldt)
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers