Set onlink routes for all subnets on an external network

Bug #1323894 reported by OpenStack Infra on 2014-05-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openstack-manuals
Low
Unassigned

Bug Description

https://review.openstack.org/90250
commit fc7cffedbe60ae9da7963373e9072c55700fce5f
Author: Carl Baldwin <email address hidden>
Date: Thu Apr 24 23:06:10 2014 +0000

    Set onlink routes for all subnets on an external network

    The addition of the on-link routes gives us some freedom to allocate a
    router's IP address from any one of multiple subnets on one external
    network. Different routers can get their IPs from different subnets and
    they still have direct on-link connectivity to each other. For example,
    one router with its primary IP from 10.0.0.0/24 and another from
    192.168.0.0/24 can communicate directly. It is important that each
    router has on-link routes to *all* of the subnets.

    Any router can host floating ips from any of the subnets regardless of
    which subnet the primary IP address comes from.

    This is an alternative to the "Multiple floating IP pools" section in
    the administration guide. It is a simpler alternative that avoids
    having to create multiple external networks. It is also more flexible
    because routers will no longer be restricted to getting floating IPs
    from the pool to which they happen to be connected.

    DocImpact
    Document the procedure for adding subnets to the external network.
    Potentially remove the existing procedure for "Multiple floating IP
    pools" from the docs.

    Change-Id: I2c283f5be0cbb6b5d350cafc1b636c300b796a7b
    Closes-Bug: #1312467

Changed in openstack-manuals:
status: New → Confirmed
Ryan Moats (rmoats) on 2014-07-09
Changed in openstack-manuals:
assignee: nobody → Ryan Moats (rmoats)
Ryan Moats (rmoats) on 2014-07-09
Changed in openstack-manuals:
status: Confirmed → In Progress
Ryan Moats (rmoats) on 2014-07-14
Changed in openstack-manuals:
status: In Progress → Fix Committed
Andreas Jaeger (jaegerandi) wrote :

I don't see where this is documented

Changed in openstack-manuals:
status: Fix Committed → Confirmed
assignee: Ryan Moats (rmoats) → nobody
importance: Undecided → Low
Tom Fifield (fifieldt) wrote :

Matt, this one is super confusing. Did you happen to cover it in the network guide so far?

Changed in openstack-manuals:
assignee: nobody → Matt Kassawara (ionosphere80)
Tom Fifield (fifieldt) wrote :

More info in the original bug at neutron here: https://bugs.launchpad.net/neutron/+bug/1312467

Lana (loquacity) wrote :

This hasn't been completed, but the Networking Guide is probably the best place for it.

tags: added: networking-guide
Changed in openstack-manuals:
assignee: Matt Kassawara (ionosphere80) → nobody
Lana (loquacity) on 2016-03-07
Changed in openstack-manuals:
milestone: none → mitaka
Chason Chan (chen-xing) on 2016-03-07
Changed in openstack-manuals:
assignee: nobody → Xing Chen (chen-xing)
Changed in openstack-manuals:
milestone: mitaka → newton
Lana (loquacity) wrote :

Chen Xing, are you working on this?

Chason Chan (chen-xing) wrote :

sorry, I am busy these days.

Changed in openstack-manuals:
assignee: Chason (chen-xing) → nobody
Lana (loquacity) wrote :

Procedure for "Multiple floating IP pools" has been removed since this bug was created (at least, I can't find a procedure in any current docs). Additionally, the Networking Guide has content about adding subnets here: http://docs.openstack.org/mitaka/networking-guide/adv-config-subnet-pools.html There is also information in the User Guide here: http://docs.openstack.org/user-guide/dashboard_create_networks.html

With this in mind, I'm closing this bug as fix released for now. If the original reporters (or other networking gurus) believe that something still needs to be added, please be specific and reopen, and I'll get that work done for you.

Changed in openstack-manuals:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers