Add script to migrate ovs or lb db to ml2 db

Bug #1296997 reported by OpenStack Infra
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openstack-manuals
Fix Released
High
Edgar Magana

Bug Description

https://review.openstack.org/76533
commit 20b2b82c02bfa0eee8b1f3224592ab0642857391
Author: Maru Newby <email address hidden>
Date: Wed Feb 26 13:09:42 2014 +0000

    Add script to migrate ovs or lb db to ml2 db

    This script migrates an ovs or lb database to work with ml2.
    The script's docstring provides details as to how it is intended to
    work.

    I've tested this manually on a trivial deployment, and would like
    to add support for testing the migration with grenade. However,
    that will have to wait until grenade support for neutron has
    merged.

    DocImpact

    Implements: blueprint ml2-deprecated-plugin-migration

    Change-Id: I1eb908c866e19f72e61f687d56a0bc391cdb4760

Tags: neutron
Tom Fifield (fifieldt)
Changed in openstack-manuals:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → icehouse
importance: Medium → High
Changed in openstack-manuals:
assignee: nobody → Steven Weston (steve.weston)
Revision history for this message
Tom Fifield (fifieldt) wrote :

upgrades chapter in the operations guide might be a good place for this

Changed in openstack-manuals:
status: Confirmed → Triaged
Revision history for this message
Edgar Magana (emagana) wrote :

Steven,

Any update about this bug? Let me know if you need help on this one.

Revision history for this message
Steven Weston (steve.weston) wrote : RE: [Bug 1296997] Re: Add script to migrate ovs or lb db to ml2 db

Hi Edgar,

I do not have an update on this yet, although I plan to commit my changes for review this evening. If my understanding is correct, this bug is about documenting the database migration process (which you have already done a great job of in the docstring ;-)) in the upgrades chapter of the Operations Guide. Does that sound right?

Thanks,
Steve

________________________________
From: Edgar Magana (<email address hidden>)<mailto:Edgar%20Magana%20(<email address hidden>)>
Sent: Friday, May 30, 2014 04:31 PM
To: Steven Weston (<email address hidden>)<mailto:Steven%20Weston%20(<email address hidden>)>
Subject: [Bug 1296997] Re: Add script to migrate ovs or lb db to ml2 db

Steven,

Any update about this bug? Let me know if you need help on this one.

--
You received this bug notification because you are a bug assignee.
https://bugs.launchpad.net/bugs/1296997

Title:
Add script to migrate ovs or lb db to ml2 db

Status in OpenStack Manuals:
Triaged

Bug description:
https://review.openstack.org/76533
commit 20b2b82c02bfa0eee8b1f3224592ab0642857391
Author: Maru Newby
Date: Wed Feb 26 13:09:42 2014 +0000

Add script to migrate ovs or lb db to ml2 db

This script migrates an ovs or lb database to work with ml2.
The script's docstring provides details as to how it is intended to
work.

I've tested this manually on a trivial deployment, and would like
to add support for testing the migration with grenade. However,
that will have to wait until grenade support for neutron has
merged.

DocImpact

Implements: blueprint ml2-deprecated-plugin-migration

Change-Id: I1eb908c866e19f72e61f687d56a0bc391cdb4760

To manage notifications about this bug go to:
https://bugs.launchpad.net/openstack-manuals/+bug/1296997/+subscriptions

Revision history for this message
Edgar Magana (emagana) wrote :

Steven,

Yes, you are correct. Did you push any commit yet?

Revision history for this message
Steven Weston (steve.weston) wrote :

Not yet, was waiting for your confirmation. I will work on it as my first priority tomorrow.

Sent from my IQTELL Virtual Workspace

________________________________
On Monday, June 9, 2014 01:23 PM, Edgar Magana <<email address hidden><mailto:<email address hidden>>> wrote:

Steven,

Yes, you are correct. Did you push any commit yet?

--
You received this bug notification because you are a bug assignee.
https://bugs.launchpad.net/bugs/1296997

Title:
Add script to migrate ovs or lb db to ml2 db

Status in OpenStack Manuals:
Triaged

Bug description:
https://review.openstack.org/76533
commit 20b2b82c02bfa0eee8b1f3224592ab0642857391
Author: Maru Newby
Date: Wed Feb 26 13:09:42 2014 +0000

Add script to migrate ovs or lb db to ml2 db

This script migrates an ovs or lb database to work with ml2.
The script's docstring provides details as to how it is intended to
work.

I've tested this manually on a trivial deployment, and would like
to add support for testing the migration with grenade. However,
that will have to wait until grenade support for neutron has
merged.

DocImpact

Implements: blueprint ml2-deprecated-plugin-migration

Change-Id: I1eb908c866e19f72e61f687d56a0bc391cdb4760

To manage notifications about this bug go to:
https://bugs.launchpad.net/openstack-manuals/+bug/1296997/+subscriptions

Tom Fifield (fifieldt)
Changed in openstack-manuals:
milestone: icehouse → juno
Revision history for this message
Matt Kassawara (ionosphere80) wrote :

I think we can close this bug since the operations guide contains instructions for OVS to ML2 migration.

Revision history for this message
Edgar Magana (emagana) wrote :

I do agree with Matt's suggestion. Let's close it.

Changed in openstack-manuals:
assignee: Steven Weston (steve.weston) → Edgar Magana (emagana)
status: Triaged → Fix Committed
Revision history for this message
Matt Kassawara (ionosphere80) wrote :

Should this be fix released?

Changed in openstack-manuals:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers