Enable to select an RPC handling plugin under Metaplugin

Bug #1295451 reported by OpenStack Infra
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openstack-manuals
Fix Released
Medium
Nachi Ueno

Bug Description

https://review.openstack.org/79858
commit b98704e80b030f3a7db60cf244e29521008e94f2
Author: Itsuro Oda <email address hidden>
Date: Tue Dec 17 10:16:51 2013 +0900

    Enable to select an RPC handling plugin under Metaplugin

    Multiple plugins under metaplugin become 'q-plugin' topic
    consumers and a request from an agent is handled by one of
    them randomly. Fortunatly most of RPC callbacks are common
    for plugins but a problem occurs if an RPC is not supported
    by the received plugin.

    This is one of risks when using metaplugin. Fundamental fix
    of this problem (such as RPC delegation handling of metaplugin)
    is difficult since each plugin needs to modify.
    But when only one plugin has plugin specific RPCs and other
    RPCs are independet of plugins, if the plugin can be selected
    for RPC handling, the problem does not happen. Typical use
    case of metaplugin such as combination of an agent-based
    plugin and a controller-based plugin often applies to this
    condition.

    This patch adds 'rpc_flavor' configuration parameter to
    select an RPC handling plugin. If 'rpc_flavor' is specified,
    only the specified plugin becomes 'q-plugin' topic consumer.
    If 'rpc_flavor' is not specified, the behavior is same as
    previous one.

    Change-Id: If133b054bba53829cebe63c1e0ebe6099eb1fd95
    Closes-bug: #1267330
    DocImpact

Tags: neutron
Tom Fifield (fifieldt)
Changed in openstack-manuals:
status: New → Confirmed
milestone: none → icehouse
importance: Undecided → Medium
Nachi Ueno (nati-ueno)
Changed in openstack-manuals:
assignee: nobody → Nachi Ueno (nati-ueno)
Revision history for this message
Edgar Magana (emagana) wrote :

Nachi, Any update on this one?

Revision history for this message
Nachi Ueno (nati-ueno) wrote :

I supposed this one solved by updateing help string in neutron code
Let me check

Tom Fifield (fifieldt)
Changed in openstack-manuals:
milestone: icehouse → juno
Revision history for this message
Nachi Ueno (nati-ueno) wrote :
Changed in openstack-manuals:
status: Confirmed → Fix Committed
Tom Fifield (fifieldt)
Changed in openstack-manuals:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers