Create new IPv6 attributes for Subnets

Bug #1293897 reported by OpenStack Infra
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openstack-manuals
Fix Released
Medium
Andreas Jaeger

Bug Description

https://review.openstack.org/52983
commit 2a4e50caeaa271937a23ab7c052c7e9c47c1933f
Author: Sean M. Collins <email address hidden>
Date: Thu Jan 30 14:12:17 2014 -0500

    Create new IPv6 attributes for Subnets

    * Introduces two new optional attributes for Subnets:
      * ipv6_ra_mode
      * ipv6_address_mode

    Both attributes accept the following values:

    * dhcpv6-stateful
    * dhcpv6-stateless
    * slaac

    In addition to these values, additional behaviors are specified for
    when only one of the attributes is set. For example, a Neutron network
    that uses a physical router as a gateway, that transmits ICMPv6 Router
    Advertisement packets to configure hosts on the network will create
    Neutron Subnets that have ipv6_ra_mode *not* set, and ipv6_address_mode
    set to 'slaac' so that Neutron will calculate EUI64 addresses for
    each port assigned to the subnet, and not spawn a Dnsmasq process.

    These attributes maintain backwards compatability with the enable_dhcp
    Subnet attribute, by requiring a subnet with these attributes to also
    have enable_dhcp set to True.

    DocImpact

    Implements bp ipv6-two-attributes
    Change-Id: I5b2313fff5dca1c16ff939fdc4397d7f95ba3ba5

Tom Fifield (fifieldt)
Changed in openstack-manuals:
status: New → Confirmed
milestone: none → icehouse
importance: Undecided → Medium
Revision history for this message
Sean M. Collins (scollins) wrote :

Putting my name on this one, but will probably split into a couple pieces so we an delegate to the Neutron ipv6 subteam for the combinations

Changed in openstack-manuals:
assignee: nobody → Sean M. Collins (scollins)
Revision history for this message
Edgar Magana (emagana) wrote :

Sean, Any update on this one?

Revision history for this message
Sean M. Collins (scollins) wrote :

Not yet - we should also change the milestone to Juno since the attributes were hidden in the Icehouse release.

Anne Gentle (annegentle)
Changed in openstack-manuals:
milestone: icehouse → juno
Revision history for this message
Edgar Magana (emagana) wrote :

Sean, The milestone has been changed to Juno by Anne. Let me know if you will be able to work on this by Juno-2

Revision history for this message
Sean M. Collins (scollins) wrote :

Subscribing Shilla to this bug, to see if she and I can pair up on this.

Revision history for this message
Tom Fifield (fifieldt) wrote :

Hi all,

Any progress on this bug? It would be great to have some IPv6 docs for Juno...

Revision history for this message
Victor Howard (victor-r-howard) wrote :

I'm going to take a look, will provide an update as soon as I can Tom, thanks.

Changed in openstack-manuals:
assignee: Sean M. Collins (scollins) → Victor Howard (victor-r-howard)
Tom Fifield (fifieldt)
Changed in openstack-manuals:
milestone: juno → kilo
tags: added: icehouse
Tom Fifield (fifieldt)
Changed in openstack-manuals:
milestone: kilo → liberty
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix proposed to openstack-manuals (master)

Related fix proposed to branch: master
Review: https://review.openstack.org/181435

Changed in openstack-manuals:
status: Confirmed → In Progress
assignee: Victor Howard (victor-r-howard) → Sean M. Collins (scollins)
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Change abandoned on openstack-manuals (master)

Change abandoned by Sean M. Collins (<email address hidden>) on branch: master
Review: https://review.openstack.org/181435
Reason: Going to combine this all into one review

Changed in openstack-manuals:
assignee: Sean M. Collins (scollins) → Tom Fifield (fifieldt)
Changed in openstack-manuals:
assignee: Tom Fifield (fifieldt) → Andreas Jaeger (jaegerandi)
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to openstack-manuals (master)

Reviewed: https://review.openstack.org/181049
Committed: https://git.openstack.org/cgit/openstack/openstack-manuals/commit/?id=099910927d813e581bc564a260d4d1dde29d1e0b
Submitter: Jenkins
Branch: master

commit 099910927d813e581bc564a260d4d1dde29d1e0b
Author: Sean M. Collins <email address hidden>
Date: Thu May 7 11:58:53 2015 -0400

    IPv6 manual for OpenStack Networking

    Co-Authored-By: John Joyce <email address hidden>
    Co-Authored-By: Rohit Agarwalla <email address hidden>

    Change-Id: Id3b3e40cfcd21c725a8aae4218b256b90ba78d01
    Closes-Bug: #1293897

Changed in openstack-manuals:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/openstack-manuals 15.0.0

This issue was fixed in the openstack/openstack-manuals 15.0.0 release.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers