Driver for IBM SONAS and Storwize V7000 Unified

Bug #1284215 reported by OpenStack Infra on 2014-02-24
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
openstack-manuals
Medium
Tom Fifield

Bug Description

https://review.openstack.org/64290
commit 2e323ba7b154c6bdb76a4c018e99004dabcb8420
Author: Nilesh Bhosale <email address hidden>
Date: Fri Dec 27 09:02:56 2013 +0530

    Driver for IBM SONAS and Storwize V7000 Unified

    The IBM NAS Driver currently implemented to work over NFS protocol,
    and implements required set of features for OpenStack Icehouse release,
    using the features of these storage products. It allows IBM® SONAS®
    and Storwize® V7000 Unified filers to host storage for OpenStack
    environment by integrating with Openstack Cinder service.

    DocImpact

    Change-Id: I0d630bf7e69454b88e9d1e93b4099631f6138204
    Implements: blueprint ibm-nas-volume-driver
    Related-Bug: #1281152

Tom Fifield (fifieldt) on 2014-02-25
Changed in openstack-manuals:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → icehouse
Tom Fifield (fifieldt) wrote :

add the appropriate statements to the config reference drivers section

Changed in openstack-manuals:
status: Confirmed → Triaged
Nilesh Bhosale (nilesh-bhosale) wrote :

This is a new Cinder driver added in the Icehouse and needs the document updates ASAP.
Please let me know if any additional information is needed with regards to this driver.

Thanks,
Nilesh

Tom Fifield (fifieldt) on 2014-06-25
Changed in openstack-manuals:
milestone: icehouse → juno
Andreas Jaeger (jaegerandi) wrote :

Nilesh, here's the current documentation:

http://docs.openstack.org/trunk/config-reference/content/ibm-storwize-svc-driver.html

Could you explain what needs to be updated, please?

Sasikanth Eda (sasikanth) wrote :

Thanks Andreas, for looking in to this bug. I apologize for not making clear in the DocImpact flag.

The link you have pointed is related to storwize_svc.py which is a different product family and the current bug is related to adding documentation for a new driver (ibmnas.py).

The new driver (https://github.com/openstack/cinder/blob/master/cinder/volume/drivers/ibm/ibmnas.py) is built for SONAS, Storwize V7000 Unified products and it is based on nfs protocol.

Tom Fifield (fifieldt) on 2015-02-27
Changed in openstack-manuals:
milestone: juno → kilo
tags: added: icehouse
Tom Fifield (fifieldt) on 2015-05-01
Changed in openstack-manuals:
milestone: kilo → liberty
Gauvain Pocentek (gpocentek) wrote :

Since the doc team doesn't have access to the hardware it's up to the vendor or to the driver author to provide the documentation. Thanks.

Tom Fifield (fifieldt) wrote :

All the config options appear to be in

common/tables/cinder-nas.xml

tags: added: autogenerate-config-docs
Tom Fifield (fifieldt) wrote :

which is included under misc

Tom Fifield (fifieldt) wrote :

block-storage/section_misc.xml: <xi:include href="../../common/tables/cinder-nas.xml"/>

Tom Fifield (fifieldt) wrote :

There's also the ibmnas flagmapping.

block-storage/section_misc.xml: <xi:include href="../../common/tables/cinder-ibmnas.xml"/>

These two files should be merged, a stub driver page with an appropriate heading created and the include fixed up

Changed in openstack-manuals:
assignee: nobody → Tom Fifield (fifieldt)

Fix proposed to branch: master
Review: https://review.openstack.org/220413

Changed in openstack-manuals:
status: Triaged → In Progress

Reviewed: https://review.openstack.org/220413
Committed: https://git.openstack.org/cgit/openstack/openstack-manuals/commit/?id=45363e935a44bd2292a639c0925a11318f75f647
Submitter: Jenkins
Branch: master

commit 45363e935a44bd2292a639c0925a11318f75f647
Author: Tom Fifield <email address hidden>
Date: Fri Sep 4 14:45:30 2015 +0800

    Add config reference for IBM SONAS/7k cinder driver

    Adds a stub section for the IBM SONAS and Storwize V7000 Unified
    driver for cinder.

    Change-Id: If072eaed3e7362b69f21cd579b5355f5c0d90932
    Closes-Bug: 1284215

Changed in openstack-manuals:
status: In Progress → Fix Released

This issue was fixed in the openstack/openstack-manuals 15.0.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers