Return request-id in API response

Bug #1278281 reported by OpenStack Infra on 2014-02-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openstack-manuals
Medium
Tom Fifield

Bug Description

https://review.openstack.org/58270

Dear documentation bug triager. This bug was created here because we did not know how to map the project name "openstack/neutron" to a launchpad project name. This indicates that the notify_impact config needs tweaks. You can ask the OpenStack infra team (#openstack-infra on freenode) for help if you need to.

commit 048faa57037d30c46205dd3dedec45fea62ef2b1
Author: Akihiro Motoki <email address hidden>
Date: Thu Dec 5 15:55:31 2013 +0900

    Return request-id in API response

    Import RequestIdMiddleware from oslo which ensures to request-id
    in API response. CatchErrorsMiddleware is also imported to ensure
    all internal exceptions are caught outermost.
    api-paste.ini is updated to use them.

    KeystonAuthContext middleware is updated so that it uses
    request-id generated by RequestIdMiddleware.

    Add middleware to openstack.conf and import all modules
    under middleware directory from oslo.

    DocImpact UpgradeImpact
    This patch adds new WSGI middlewares "request_id" and "catch_errors".
    They needs to be added to api-paste.ini when upgrading.

    Change-Id: Icf01b7de697ef50bef53212da2cf520d1ff78b88
    Closes-Bug: #1239923

Anne Gentle (annegentle) wrote :

Seems to affect upgrade instructions.

no longer affects: openstack-api-site
Changed in openstack-manuals:
status: New → Confirmed
tags: added: ops-guide
Changed in openstack-manuals:
importance: Undecided → Medium
Tom Fifield (fifieldt) on 2015-06-15
Changed in openstack-manuals:
status: Confirmed → Triaged
Tom Fifield (fifieldt) wrote :

This was for Icehouse --> Juno upgrade instructions. However, after those instructions were written and tested, it wasn't necessary (http://docs.openstack.org/openstack-ops/content/upgrade-icehouse-juno.html ). This is likely because packaging takes care of it. api-paste.ini isn't modified in the normal case, so it should just work

Changed in openstack-manuals:
assignee: nobody → Tom Fifield (fifieldt)
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers