Neutron settings for Pacemaker out-of-date

Bug #1252131 reported by Stuart Longland
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
openstack-manuals
Fix Released
Critical
Stephen Gordon

Bug Description

Hi,

I've been beating my head against a few bugs on this document. Either bugs in the document, or bugs in my understanding of how everything needs to be done.

I'm trying to set up corosync/pacemaker to manage Neutron's singleton service agents: dhcp, l3 and metadata.

Firstly, it tells us to download the following:
https://raw.github.com/madkiss/openstack-resource-agents/master/ocf/neutron-l3-agent
https://raw.github.com/madkiss/openstack-resource-agents/master/ocf/neutron-dhcp-agent
https://raw.github.com/madkiss/openstack-resource-agents/master/ocf/neutron-metadata-agent

Except that two of these lead to 404 pages. Fine, a bit of digging revealed that the former two have swapped names around, and so the links *should* be:
https://raw.github.com/madkiss/openstack-resource-agents/master/ocf/neutron-agent-l3
https://raw.github.com/madkiss/openstack-resource-agents/master/ocf/neutron-agent-dhcp

Naturally that means the code snippets need work too:

root@node:/tmp/neutron-deploy# cat 12-dhcp-agent
primitive p_neutron-dhcp-agent ocf:openstack:neutron-dhcp-agent \
        params config="/etc/neutron/neutron.conf" \
        plugin_config="/etc/neutron/dhcp_agent.ini" \
        op monitor interval="30s" timeout="30s"
root@node:/tmp/neutron-deploy# crm configure < 12-dhcp-agent
lrmadmin[2098]: 2013/11/18_13:39:39 ERROR: lrm_get_rsc_type_metadata(578): got a return code HA_FAIL from a reply message of rmetadata with function get_ret_from_msg.
ERROR: 4: ocf:openstack:neutron-dhcp-agent: could not parse meta-data:
ERROR: 4: ocf:openstack:neutron-dhcp-agent: could not parse meta-data:
ERROR: 4: ocf:openstack:neutron-dhcp-agent: no such resource agent

If I update the names, as I discovered the hard way:

root@node:/tmp/neutron-deploy# cat 12-dhcp-agent
primitive p_neutron-dhcp-agent ocf:openstack:neutron-agent-dhcp \
        params config="/etc/neutron/neutron.conf" \
        plugin_config="/etc/neutron/dhcp_agent.ini" \
        op monitor interval="30s" timeout="30s"
root@node:/tmp/neutron-deploy# crm configure < 12-dhcp-agent
ERROR: 4: p_neutron-dhcp-agent: parameter plugin_config does not exist

Yet, the documentation tells me that I should specify plugin_config. It doesn't work without either, it just plain refuses to start, for reasons that remain a mystery for now. The same problems exist for the l3 agent and metadata agent scripts.

Regards,
Stuart Longland
-----------------------------------
Built: 2013-11-17T23:24:56 00:00
git SHA: acc8142da50f340a58e780318167505bf001f7f7
URL: http://docs.openstack.org/high-availability-guide/content/_adding_neutron_l3_agent_resource_to_pacemaker.html
source File: file:/home/jenkins/workspace/openstack-ha-guide/doc/high-availability-guide/bk-ha-guide.xml
xml:id: _adding_neutron_l3_agent_resource_to_pacemaker

Tom Fifield (fifieldt)
Changed in openstack-manuals:
status: New → Confirmed
importance: Undecided → High
milestone: none → havana
Revision history for this message
Tom Fifield (fifieldt) wrote :

The HA guide is not useful unless this bug gets fixed - marking as critical.

Changed in openstack-manuals:
importance: High → Critical
Revision history for this message
Xiaolin Zhang (zhangxiaolins) wrote :

Faced the same issue here, and I believe there are some minor errors in ocf scripts.
after tuning with the following patch, pacemaker works fine.

============
Last updated: Tue Jan 14 19:04:18 2014
Last change: Tue Jan 14 19:04:17 2014 via crmd on TJN1-A3-0607-network1
Stack: openais
Current DC: TJN1-A3-0607-network1.cp.chinacache.com - partition WITHOUT quorum
Version: 1.1.6-9971ebba4494012a93c03b40a2c58ec0eb60f50c
2 Nodes configured, 2 expected votes
3 Resources configured.
============

Online: [ TJN1-A3-0607-network1 ]

 Resource Group: g_neutron-network
     p_neutron-agent-dhcp (ocf::openstack:neutron-agent-dhcp): Started TJN1-A3-0607-network1
     p_neutron-agent-l3 (ocf::openstack:neutron-agent-l3): Started TJN1-A3-0607-network1
     p_neutron-metadata-agent (ocf::openstack:neutron-metadata-agent): Started TJN1-A3-0607-network1

Revision history for this message
Xiaolin Zhang (zhangxiaolins) wrote :

Patches for ocf scripts for pacemaker.

Changed in openstack-manuals:
assignee: nobody → Xiaolin Zhang (zhangxiaolins)
Revision history for this message
Edgar Magana (emagana) wrote :

This patch should help the Active/Standby deployment of these agents.
However, DHCP could be running in Active/Active mode since Grizzly:
http://docs.openstack.org/trunk/config-reference/content/app_demo_multi_dhcp_agents.html

Tom,
HA Neutron documentation needs to be updated properly. I will open a new ticket to do this.

Edgar

Revision history for this message
Stuart Longland (redhatter) wrote : Re: [Bug 1252131] Re: Neutron settings for Pacemaker out-of-date

On 17/01/14 02:28, Edgar Magana wrote:
> This patch should help the Active/Standby deployment of these agents.
> However, DHCP could be running in Active/Active mode since Grizzly:
> http://docs.openstack.org/trunk/config-reference/content/app_demo_multi_dhcp_agents.html

Whilst you're in there:

> Runs Nova compute, the Neutron L2 agent and DCHP agent
                                             ^^^^^^
I think that's a typo.

Regards,
--
Stuart Longland
Contractor
     _ ___
\ /|_) | T: +61 7 3535 9619
 \/ | \ | 38b Douglas Street F: +61 7 3535 9699
   SYSTEMS Milton QLD 4064 http://www.vrt.com.au

Revision history for this message
Xiaolin Zhang (zhangxiaolins) wrote :

Edgar, thanks for your clarifications. I have put a pull request on madkiss/openstack-resource-agents [https://github.com/madkiss/openstack-resource-agents/pull/15] to fix the pacemaker scripts.

Revision history for this message
Edgar Magana (emagana) wrote :
Changed in openstack-manuals:
assignee: Xiaolin Zhang (zhangxiaolins) → Edgar Magana (emagana)
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to openstack-manuals (master)

Fix proposed to branch: master
Review: https://review.openstack.org/75645

Changed in openstack-manuals:
assignee: Edgar Magana (emagana) → Stephen Gordon (sgordon)
status: Confirmed → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to openstack-manuals (master)

Reviewed: https://review.openstack.org/75645
Committed: https://git.openstack.org/cgit/openstack/openstack-manuals/commit/?id=1a2e3dd02779b3e68f51a2f2cbd77451bfddd259
Submitter: Jenkins
Branch: master

commit 1a2e3dd02779b3e68f51a2f2cbd77451bfddd259
Author: Stephen Gordon <email address hidden>
Date: Sat Feb 22 14:04:43 2014 -0500

    Use correct URLs for pacemaker scripts

    Updated URLs in HA guide to point to new location of pacemaker scripts.

    Change-Id: I1a5ea97e2ec7cad9270f3b815fa5caea9e3d4ff1
    Closes-Bug: #1252131

Changed in openstack-manuals:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/openstack-manuals 15.0.0

This issue was fixed in the openstack/openstack-manuals 15.0.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers