Duplicates in generated tables

Bug #1226464 reported by Andreas Jaeger on 2013-09-17
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
openstack-manuals
High
Lee Li

Bug Description

Taking common/tables/nova-db.xml as an example:

looking at https://bugs.launchpad.net/openstack-manuals/+bug/1205060 I
noticed in the table nova-db.xml a number of duplications which looks wrong to me:

                      <td>backend=sqlalchemy</td>
                       <td>(StrOpt) The backend to use for db</td>

                      <td>db_backend=sqlalchemy</td>
                       <td>(StrOpt) The backend to use for bare-metal
database</td>

I understood the bugreport that
[DEFAULT]
db_backend=sqlalchemy

has been moved to
[database]
backend=sqlalchemy

See also the diff here:
https://review.openstack.org/#/c/34671/17/nova/openstack/common/db/api.py

So, somehow the table looks wrong to me, it should either only document backend as new one - or point out that one is old, the other new.

Andreas Jaeger (jaegerandi) wrote :

looking at nova.flagmappings, I see:
db_backend baremetal
db_backend db

Is that already the problem?

Anne Gentle (annegentle) wrote :

I'm guessing that the nova.flagmappings should read:

db_backend baremetal
backend db

And then re-run the table generation.

Changed in openstack-manuals:
status: New → Confirmed
importance: Undecided → High
Andreas Jaeger (jaegerandi) wrote :

There's a db_backend in [baremetal]. Our tool needs to handle the groups as well, since options in different groups can have different defaults and descriptions

Stephen Gordon (sgordon) on 2013-09-27
Changed in openstack-manuals:
milestone: none → havana
Phil Hopkins (phil-hopkins-a) wrote :

There is another one at:
http://docs.openstack.org/trunk/config-reference/content/networking-options-metadata.html

auth_strategy=keystone

is listed twice.

Nermina Miller (nerminamiller) wrote :

Can we physically remove duplicates even though the tables are auto-generated?

Andreas Jaeger (jaegerandi) wrote :

Nermina, yes we can - but please state it explicitly in your commit message.

Nermina Miller (nerminamiller) wrote :

Will do!

Changed in openstack-manuals:
assignee: nobody → Nermina Miller (nerminamiller)
Nermina Miller (nerminamiller) wrote :

Sorry all! I forgot to use the closes-bug feature, but the fix is here: https://review.openstack.org/#/c/51774/.

Changed in openstack-manuals:
status: Confirmed → In Progress
Tom Fifield (fifieldt) on 2013-10-18
Changed in openstack-manuals:
status: In Progress → Fix Released
Anne Gentle (annegentle) wrote :

Marking Confirmed as the root cause fix (the autogeneration causing duplicates) is not yet complete.

Changed in openstack-manuals:
status: Fix Released → Confirmed
Changed in openstack-manuals:
assignee: Nermina Miller (nerminamiller) → nobody
Lee Li (lilinguo) on 2013-12-25
Changed in openstack-manuals:
assignee: nobody → Lee Li (lilinguo)

Fix proposed to branch: master
Review: https://review.openstack.org/64387

Changed in openstack-manuals:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/64387
Committed: https://git.openstack.org/cgit/openstack/openstack-manuals/commit/?id=2b48e3facbadcc5a9ad83c503d6b47802df7cc6a
Submitter: Jenkins
Branch: master

commit 2b48e3facbadcc5a9ad83c503d6b47802df7cc6a
Author: llg8212 <email address hidden>
Date: Mon Dec 30 11:20:03 2013 +0800

    Duplicates in generated tables

    In the table nova-db.xml, the backend and db_backend are duplicates in generated
    tables. The db_backend should be deprecated.

    See also the diff here:
    https://review.openstack.org/#/c/34671/17/nova/openstack/common/db/api.py

    The two backends should be distinguished.

    Change-Id: I7b53a95a4d79bbe52041f39a06653e0a0fcb6523
    Closes-Bug:#1226464

Changed in openstack-manuals:
status: In Progress → Fix Released

This issue was fixed in the openstack/openstack-manuals 15.0.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints