'%' in the translation strings will cause an error in Transifex

Bug #1192091 reported by Ying Chun Guo
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
openstack i18n
Fix Released
Undecided
Unassigned
openstack-manuals
Fix Released
Medium
Ying Chun Guo

Bug Description

One issue reported by translator:

Some sentences contains "%" character followed by a space and it seems Transifex recognizes the sequence as a conversion specifier
by mistake. For example, "Once you have reproduced the issue (or are 100% confident that this is indeed a valid bug) and have permissions to do so, set:" contains "% c". When translating the sentence, Transifex warns us that there is no "% c" in the translation and we cannot save the translated sentence. Now we insert a dummy word such "%c_dummy" to avoid this issue. Or should we escape % character by %%?

Whether the issue is a bug in Transifex or not, we should avoid to use "%" in translation strings. We can replace "%" with "%%" in the generated PoT files and then convert back to "%" when generating HTML files.

We should add this function in the translation scripts.

Tags: translation
Changed in openstack-manuals:
importance: Undecided → Medium
status: New → Confirmed
Tom Fifield (fifieldt)
Changed in openstack-i18n:
status: New → Confirmed
Revision history for this message
Ying Chun Guo (daisy-ycguo) wrote :

I think it has been fixed by Transifex.
Now there will be a warning, but it won't block the save action.

Tom Fifield (fifieldt)
Changed in openstack-i18n:
status: Confirmed → Fix Released
Changed in openstack-manuals:
status: Confirmed → Fix Released
Changed in openstack-manuals:
status: Fix Released → Fix Committed
Changed in openstack-i18n:
status: Fix Released → Fix Committed
Tom Fifield (fifieldt)
Changed in openstack-manuals:
status: Fix Committed → Fix Released
Changed in openstack-i18n:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers