OpenStack Compute Administration Manual - current: compute logical architecture incomplete

Bug #1160757 reported by Marco CONSONNI on 2013-03-27
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
openstack-manuals
Wishlist
Tom Fifield

Bug Description

This is NOT a bug submission; it's a proposal for (maybe) improving the Compute Logical Architecture paragraph (see http://docs.openstack.org/trunk/openstack-compute/admin/content/overview-compute-arch.html).

I'm attaching some material for a better defining what I mean (see attachment).

In my opinion, the logical architecture should list all the software components an administrator needs to know in order to understand the platform. At the moment the list seems to be incomplete because some major components are not mentioned and some have a too short description for having a clear view of the architecture.

I made an exercise for listing all the nova major components and to provide very basic information on them.
In the attached file you can find my proposal in Word format.

Most of the material was taken from existing documentation but some components need more info (e.g. nova-cert).

I only made the exercise for nova but I'm planning to do the same for other subsystems/projects (glance, cinder, horizon, ...).

Your comments are more than welcome.

Marco CONSONNI (marco-consonni) wrote :
Anne Gentle (annegentle) wrote :

Really like this idea and I'm studying it, thanks!

Marco CONSONNI (marco-consonni) wrote :

Find attached the 2nd episode.

Tom Fifield (fifieldt) wrote :

IMO, this is well worth discussing at the summit too!

Changed in openstack-manuals:
status: New → Confirmed
importance: Undecided → Wishlist
Anne Gentle (annegentle) wrote :

I've been reading through the attachments, and starting to wonder if we should stop maintaining install guides and write architecture and configuration guides instead. Would love to discuss at the Summit!

Marco CONSONNI (marco-consonni) wrote :

Dear Anne and Tom,

unfortunately I won't be able to join you at the Summit.
I'm really sorry about that :(

Anyway, I can share with you and others some ideas I've got on what I prepared.

The material I've prepared (and I'm trying to extend when I have some time to spend on it :( ) is meant to describe the architecture of the system regardless of the way it is deployed on physical nodes.
I think that it is very a very important aspect that was already there in the document. I just re-organized the contents.
There are some reasons for this distinction.

For example, before deciding where you put the "pieces" (deployment) and how to arrange the "pieces" (installation instructions), you really need to understand the "pieces". What they do, the relationships and what they use or are based on (enabling technologies like the DB, the queue, virtualization, etc...).
In my opinion, if you have this kind of information before going into the details like deployment and installation/configuration, you probably have the key for understanding *why* you do something. This helps you when, for example, you face some problems in the installation and the installation instructions doesn't tell you how to get out of troubles (which is normal because any manual installation has it's own problems due to so many factors that the installation guide can't cover).

In this perspective, the architecture should complement other documents like installation guides (very useful) and configuration guides.

Maybe the architecture should be thought as a "module" that could be reused in several documents; in those documents where you need to understand the big picture before going into details.
In this case, the shorter the architecture description is, the better!
We can also think to an "extended version" and a very short version specifically designed for being reused in several contexts.

Very long preaching :)

Cheers.

Marco CONSONNI (marco-consonni) wrote :

I reading what I wrote: sorry for the syntax errors!
Shame on me!

Anne Gentle (annegentle) wrote :

I like this direction -- and I'll incorporate it now in to the install guide, sooner the better. We need more understanding from people who come to the install guide that it's just guidance, not the "Official Only Way To Install OpenStack." Thanks for this!

Changed in openstack-manuals:
assignee: nobody → Anne Gentle (annegentle)

Fix proposed to branch: master
Review: https://review.openstack.org/26950

Changed in openstack-manuals:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/26950
Committed: http://github.com/openstack/openstack-manuals/commit/83e612f403af0d69ca60c6c1f0bf277b1057da28
Submitter: Jenkins
Branch: master

commit 83e612f403af0d69ca60c6c1f0bf277b1057da28
Author: annegentle <email address hidden>
Date: Mon Apr 15 08:36:30 2013 -0500

    Adds additional details to logical architecture

    fix bug 1160757

    Patchset addresses typos and grammatical errors.

    Change-Id: I544317732b662a084e2018a83ee657f5c433f3b6

Changed in openstack-manuals:
status: In Progress → Fix Released
Anne Gentle (annegentle) wrote :

Reopening so that we can add more info about nova-cert. Mailing list post:

Miller, Mark M (EB SW Cloud - R&D - Corvallis) <email address hidden>

to OpenStack
Hello,

I am trying to locate information about what services the nova-cert service provides and whether or not it can be used to distribute certificates in a cloud. After several hours of web surfing I have found very little information. I am writing in hopes that someone can point me to a tutorial that describes what this service can and cannot do.

Thank you in advance,

Mark

Changed in openstack-manuals:
status: Fix Released → Confirmed
Anne Gentle (annegentle) on 2014-03-24
Changed in openstack-manuals:
assignee: Anne Gentle (annegentle) → nobody
Tom Fifield (fifieldt) on 2014-05-01
Changed in openstack-manuals:
milestone: none → juno

Hello,

About nova-cert, I found this:

"nova-cert is a server daemon that serves the Nova Cert service for X509 certificates. Used to generate certificates for euca-bundle-image. Only needed for EC2 API."

https://github.com/openstack/nova/blob/master/doc/source/man/nova-cert.rst

Fix proposed to branch: master
Review: https://review.openstack.org/143839

Changed in openstack-manuals:
assignee: nobody → Tom Fifield (fifieldt)
status: Confirmed → In Progress
Tom Fifield (fifieldt) on 2014-12-24
Changed in openstack-manuals:
milestone: juno → kilo

Reviewed: https://review.openstack.org/143839
Committed: https://git.openstack.org/cgit/openstack/openstack-manuals/commit/?id=9f3306f1dfe4c0f85d4479e055bb00e320cb7647
Submitter: Jenkins
Branch: master

commit 9f3306f1dfe4c0f85d4479e055bb00e320cb7647
Author: Tom Fifield <email address hidden>
Date: Wed Dec 24 22:55:22 2014 +0900

    Add nova-cert to the compute getstart

    An introduction to the nova-cert module was missing
    from the compute introduction. This adds an entry to the
    list for it.

    Change-Id: I3e805ed953d27a48e007e2776ae37205726704d6
    Closes-Bug: 1160757

Changed in openstack-manuals:
status: In Progress → Fix Released

This issue was fixed in the openstack/openstack-manuals 15.0.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers