Task: Document keystone middleware situation in operator docs

Reported by Anne Gentle on 2012-09-26
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
openstack-manuals
Medium
Everett Toews

Bug Description

I've been following the ML but I'm still not entirely sure where operators obtain and configure middleware for making Swift work with Keystone - and also Glance too. Need to ensure this is documented clearly.

Tom Fifield (fifieldt) on 2012-09-26
Changed in openstack-manuals:
status: New → Confirmed
importance: Undecided → Medium
Anne Gentle (annegentle) wrote :

The repo is at https://github.com/fujita/swift3.git. This is referenced now in the documentation.

It's also packaged as swift-python-s3 on ubuntu.

To get it to work with Swift 1.7, you must use the 1.3.7 branch of the fujita/swift3 repo.

Anne Gentle (annegentle) wrote :

To close this bug completely , add a note to doc/src/docbkx/openstack-object-storage-admin/objectstorageadmin.xml saying:

To use S3 with Swift 1.7 or lower versions, you must use the 1.3.7 branch of the fujita/swift3 repo.

Changed in openstack-manuals:
assignee: nobody → Everett Toews (everett-toews)

Fix proposed to branch: master
Review: https://review.openstack.org/18086

Changed in openstack-manuals:
status: Confirmed → In Progress
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/18086
Committed: http://github.com/openstack/openstack-manuals/commit/df586908109e63bdcb7e62d8f2a78ac6e2b5e6e8
Submitter: Jenkins
Branch: master

commit df586908109e63bdcb7e62d8f2a78ac6e2b5e6e8
Author: Everett Toews <email address hidden>
Date: Thu Dec 13 15:20:11 2012 -0600

    Added note about using tag v1.7 of fujita/swift3 repo with Swift version 1.7.0 and earlier.

    Change-Id: I3cf58c997b0aa5bf864fd9f0b5200f181dfed45c
    Fixes: bug #1057059

Everett Toews (everett-toews) wrote :

@annegentle

Fixed. Turns out it's actually the *v1.7* *tag* of the fujita/swift3 repo that works with Swift 1.7 or lower versions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers