Mistake in Newton Installation Guide

Bug #1691900 reported by Youhei Tooyama
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openstack i18n
Invalid
Undecided
Unassigned
openstack-manuals
Fix Released
High
Ian Y. Choi

Bug Description

This Document are OpenStack Newton.
But Document says to install Ocata.

about CentOS
yum install centos-release-openstack-ocata

yum install centos-release-openstack-newton

about RHEL
yum install https://rdoproject.org/repos/rdo-release.rpm

yum install https://repos.fedorapeople.org/repos/openstack/openstack-newton/rdo-release-newton-5.noarch.rpm

This bug tracker is for errors with the documentation, use the following as a template and remove or add fields as you see fit. Convert [ ] into [x] to check boxes:

- [x] This doc is inaccurate in this way: ______
- [ ] This is a doc addition request.
- [x] I have a fix to the document that I can paste below including example: input and output.

-----------------------------------
Release: 15.0.0 on 2017-05-18 19:32
SHA: 27f002a754e77d621332f30353044a91e449dd79
Source: https://git.openstack.org/cgit/openstack/openstack-manuals/tree/doc/install-guide/source/environment-packages.rst
URL: https://docs.openstack.org/newton/ja/install-guide-rdo/environment-packages.html

description: updated
description: updated
Ian Y. Choi (ianychoi)
Changed in openstack-manuals:
assignee: nobody → Ian Y. Choi (ianychoi)
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to openstack-manuals (stable/ocata)

Fix proposed to branch: stable/ocata
Review: https://review.openstack.org/466529

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to openstack-manuals (stable/ocata)

Reviewed: https://review.openstack.org/466529
Committed: https://git.openstack.org/cgit/openstack/openstack-manuals/commit/?id=c825dc8627e5c8eb4eb0b8417ad56f69c2429b9b
Submitter: Jenkins
Branch: stable/ocata

commit c825dc8627e5c8eb4eb0b8417ad56f69c2429b9b
Author: Ian Y. Choi <email address hidden>
Date: Sun May 21 12:48:54 2017 +0000

    [I18n] Fixes publishlang output directory

    This is stable/ocata branch so publishlang output directory
    should be publish-docs/ocata, not publish-docs/newton.

    Change-Id: I4760c4243b3877aa73eb34a2e7a5bd8803229163
    Closes-Bug: #1691900

tags: added: in-stable-ocata
Changed in openstack-manuals:
importance: Undecided → High
status: New → Fix Released
milestone: none → pike
Revision history for this message
Ian Y. Choi (ianychoi) wrote :

Just note that the patch fixes the root cause of this bug, and we might say that the bug is fixed :)

However, newton document needs to be updated and https://review.openstack.org/#/c/466542/ is still under review. Without landing this patch, https://docs.openstack.org/newton/ja/install-guide-ubuntu/ would not be updated.

(Olena, it would be so nice if you review https://review.openstack.org/#/c/466542/ - thanks a lot!)

Revision history for this message
Ian Y. Choi (ianychoi) wrote :

I have finally checked that the two patches were successfully landed to openstack-manuals git repository, both ocata and newton manuals were re-built and re-synced, and now https://docs.openstack.org/newton/ja/install-guide-ubuntu/ document describes "Newton" release :)

Changed in openstack-i18n:
status: New → Fix Released
Revision history for this message
Akihiro Motoki (amotoki) wrote :

It is a bug in the original manuals and not a bug in translations, so I think 'Invalid' is the right status in openstack-i18n (or "no longer affects openstack-i18n").

Changed in openstack-i18n:
status: Fix Released → Invalid
Revision history for this message
KATO Tomoyuki (kato-tomoyuki) wrote :
Changed in openstack-manuals:
status: Fix Released → Incomplete
status: Incomplete → Triaged
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to openstack-manuals (stable/newton)

Fix proposed to branch: stable/newton
Review: https://review.openstack.org/467216

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to openstack-manuals (stable/newton)

Reviewed: https://review.openstack.org/467216
Committed: https://git.openstack.org/cgit/openstack/openstack-manuals/commit/?id=90b2d1d74b7dab8060a94b7dd8b14bf613012c3d
Submitter: Jenkins
Branch: stable/newton

commit 90b2d1d74b7dab8060a94b7dd8b14bf613012c3d
Author: KATO Tomoyuki <email address hidden>
Date: Tue May 23 21:14:04 2017 +0900

    [install] change RDO packages repos for Newton

    https://rdoproject.org/repos/rdo-release.rpm points
    the latest release. Therefore, we need to use stable
    repos for the stable release.

    backport: mitaka

    Change-Id: I3eaa302e66c335e0addad2588ceba8a5ee343582
    Co-Authored-By: Youhei Tooyama <email address hidden>
    Closes-Bug: #1691900

tags: added: in-stable-newton
Changed in openstack-manuals:
status: Triaged → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to openstack-manuals (stable/mitaka)

Fix proposed to branch: stable/mitaka
Review: https://review.openstack.org/467439

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to openstack-manuals (stable/mitaka)

Reviewed: https://review.openstack.org/467439
Committed: https://git.openstack.org/cgit/openstack/openstack-manuals/commit/?id=45eda49ac4cda85ac1368f9c6d0fa00ad68c7815
Submitter: Jenkins
Branch: stable/mitaka

commit 45eda49ac4cda85ac1368f9c6d0fa00ad68c7815
Author: KATO Tomoyuki <email address hidden>
Date: Wed May 24 10:44:19 2017 +0900

    [install] change RDO packages repos for Mitaka

    https://rdoproject.org/repos/rdo-release.rpm points
    the latest release. Therefore, we need to use stable
    repos for the stable release.

    backport: mitaka

    Change-Id: I3eaa302e66c335e0addad2588ceba8a5ee343582
    Co-Authored-By: Youhei Tooyama <email address hidden>
    Closes-Bug: #1691900
    (cherry picked from commit 90b2d1d74b7dab8060a94b7dd8b14bf613012c3d)

tags: added: in-stable-mitaka
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers