Russian strings for Actions within Project->Instances page 'More Actions' dropdown are missing

Bug #1494819 reported by Timur Sufiev
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
Invalid
High
Unassigned
openstack i18n
Fix Released
Undecided
Doug Fish

Bug Description

The same page translated to other languages where unicode is used (Serbian, Japanese) looks ok.

Revision history for this message
Timur Sufiev (tsufiev-x) wrote :
Revision history for this message
Timur Sufiev (tsufiev-x) wrote :

Btw, already after attaching the screenshot I realized that 'Terminate Instances' translation is missing as well (see red button with times sign).

Doug Fish (drfish)
Changed in horizon:
status: New → Confirmed
importance: Undecided → High
Revision history for this message
Doug Fish (drfish) wrote :
Revision history for this message
Doug Fish (drfish) wrote :

Ilya - I expected to see Russian translations with 3 pluralities, but we have 4. Are you aware of why this is?

Doug Fish (drfish)
Changed in horizon:
milestone: none → liberty-rc1
Revision history for this message
Doug Fish (drfish) wrote :

I'm _certain_ this problem is caused by the strange plurality count. I can make this work by editing the Russian PO file

cd openstack_dashboard/locale/ru/LC_MESSAGES
cp django.po django.po-tmp
grep -v msgstr.2. django.po-tmp > django.po
sed -i s/msgstr.3./msgstr[2]/ django.po

and edit the plurality function to be
"Plural-Forms: nplurals=3; plural=(n%10==1 && n%100!=11 ? 0 : n%10>=2 && n"
"%10<=4 && (n%100<12 || n%100>14) ? 1 : 2);\n"

recompile the catalog
./run_tests.sh —compilemessages

Doug Fish (drfish)
Changed in openstack-i18n:
assignee: nobody → Doug Fish (drfish)
Revision history for this message
Ilya Alekseyev (ilyaalekseyev) wrote :

Doug, looks like we have 4 pluralities after migration to Zanata. Before Zanata we have 3.
Curently we can fix it in Zanata, but i think we'll discuss this issue with Daisy.

Changed in openstack-i18n:
status: New → Confirmed
Revision history for this message
Doug Fish (drfish) wrote :

Not a horizon bug - this is a translation structure issue

Changed in horizon:
status: Confirmed → Invalid
David Lyle (david-lyle)
Changed in horizon:
milestone: liberty-rc1 → none
Revision history for this message
Akihiro Motoki (amotoki) wrote :

As of liberty release, the problem is fixed.
We changed the number of plural and it seems to fix the problem.

Changed in openstack-i18n:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers