Missing /usr/lib/rpm/redhat/redhat-hardened-cc1

Bug #1424582 reported by Flavio Percoco on 2015-02-23
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
OpenStack-Gate
Undecided
Unassigned

Bug Description

2015-02-23 09:35:09.848 |
2015-02-23 09:35:09.848 | creating build/temp.linux-x86_64-2.7
2015-02-23 09:35:09.848 |
2015-02-23 09:35:09.848 | gcc -pthread -fno-strict-aliasing -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -m64 -mtune=generic -D_GNU_SOURCE -fPIC -fwrapv -DNDEBUG -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -m64 -mtune=generic -D_GNU_SOURCE -fPIC -fwrapv -fPIC -Dversion_info=(1,2,5,'final',1) -D__version__=1.2.5 -I/usr/include/mysql -I/usr/include/python2.7 -c _mysql.c -o build/temp.linux-x86_64-2.7/_mysql.o -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -m64 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -fPIC -fno-delete-null-pointer-checks -g -static-libgcc -fno-omit-frame-pointer -fno-strict-aliasing
2015-02-23 09:35:09.848 |
2015-02-23 09:35:09.848 | gcc: error: /usr/lib/rpm/redhat/redhat-hardened-cc1: No such file or directory
2015-02-23 09:35:09.848 |
2015-02-23 09:35:09.848 | error: command 'gcc' failed with exit status 1
2015-02-23 09:35:09.848 |
2015-02-23 09:35:09.848 | ----------------------------------------
2015-02-23 09:35:09.848 | Failed building wheel for MySQL-python
2015-02-23 09:35:09.848 | Failed to build MySQL-python

Christian Berendt (berendt) wrote :

Does this issue still exist or was it solved with https://review.openstack.org/#/c/157746/4 (it was merged)?

/usr/lib/rpm/redhat/redhat-hardened-cc1 is included in the package redhat-rpm-configrpm. I had a similiar issue on a local development system and installing this package solved the issue for me.

Jacek Tomasiak (skazi) wrote :

I just got this error on a fresh install of fedora 23 while trying to do ./stack.sh.

Russell Bryant (russellb) wrote :

I got this on Fedora 23. The package needed is "redhat-rpm-config".

Ehsan (azarnasab) wrote :

Still an issue on Fedora 23 I got this error when doing a pip install pyzmq

samer (samer226047-8) wrote :

am facing the same problem , Fedora 23 , pip install pandas

samer (samer226047-8) wrote :

just found the solution here, it worked for me :
http://stackoverflow.com/questions/34624428/g-error-usr-lib-rpm-redhat-redhat-hardened-cc1-no-that-file-and-directory

in short you have to install this package.
sudo dnf install redhat-rpm-config

Bertrand (brault) wrote :

This worked for me as well on Fedora 24 workstation:
fedora24 ~]# yum install redhat-rpm-config

Payas Rajan (payas-rajan) wrote :

Confirming the error in Fedora 26 alpha, pip install pandas.

dnf install redhat-rpm-config still works

Andrew (poproar) wrote :

Just installed Fedora 25 workstation x64, This error occurred when trying to (bundle) install a new jekyll instance. redhat-rpm-config got hit on ffi

John Clark (ajohnclark) wrote :

Thanks redhat-rpm-config worked, was trying to install MySQL-python and kept failing to build wheel. Using latest/up-to-date Fedora 25 workstation. Thanks a bunch.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers