"Show All" button not working

Bug #1773880 reported by Mike Chen on 2018-05-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Undecided
Unassigned
openstack-doc-tools
Undecided
Unassigned

Bug Description

On compute/placement api ref pages, "Show All" button does not have any effect when clicking on it, which I suppose is not intended.

https://developer.openstack.org/api-ref/compute/
https://developer.openstack.org/api-ref/placement/

Tags: doc Edit Tag help
jichenjc (jichenjc) on 2018-05-29
tags: added: doc
Matt Riedemann (mriedem) wrote :

The show all / hide all button was added in this change:

https://review.openstack.org/#/c/305769/

My guess is something changed which broke how that works, like the openstackdocstheme changes or something similar.

Matt Riedemann (mriedem) wrote :

Then that api-ref extension code was moved out of nova into another library:

https://review.openstack.org/#/c/316318/

That was before the nova api-ref was changed to use openstackdocstheme, so my guess is openstackdocstheme is either lacking support for the global expand/collapse or it's implemented differently somehow.

Matt Riedemann (mriedem) wrote :

This might have regressed something:

https://github.com/openstack/os-api-ref/commit/f93c467e9acfe1a7b02fa79cd7b906de5b8302eb

Anyway, I'll add os-api-ref to this bug report since that's where the code lives now.

Changed in nova:
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers