os-doc-tools doesn't have unit tests

Bug #1387716 reported by Gauvain Pocentek on 2014-10-30
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openstack-doc-tools
Wishlist
Njira Perci
openstack-manuals
Wishlist
Unassigned

Bug Description

We have no tests at all on this package, and sometimes things break on less tested scripts. The python3 port will probably be easier with unit tests at hand too.

We mostly manipulate text so these tests shouldn't be too complex to write, we just need to find time to write them :)

Changed in openstack-manuals:
importance: Undecided → Wishlist
Tom Fifield (fifieldt) on 2014-11-11
Changed in openstack-manuals:
status: New → Confirmed
tags: added: low-hanging-fruit
Tom Fifield (fifieldt) on 2015-05-01
Changed in openstack-manuals:
milestone: kilo → liberty
Diego Adolfo (diegoado) on 2015-07-14
Changed in openstack-manuals:
assignee: nobody → Diego Adolfo (diegoado)
Diego Adolfo (diegoado) on 2015-07-14
Changed in openstack-manuals:
status: Confirmed → In Progress
status: In Progress → Confirmed
Diego Adolfo (diegoado) on 2015-07-14
Changed in openstack-manuals:
assignee: Diego Adolfo (diegoado) → nobody
Asha (assarava) on 2015-08-19
Changed in openstack-manuals:
assignee: nobody → Asha (assarava)
Changed in openstack-manuals:
milestone: liberty → mitaka
Andreas Jaeger (jaegerandi) wrote :

Asha, are you still working on this?

Asha (assarava) wrote :

I just unassigned myself please proceed Andreas!

Changed in openstack-manuals:
assignee: Asha (assarava) → nobody

I would like to use this bug for the Outreachy mentoring if possible? This seems like a perfect project to get started with. Any objections?

Njira Perci (njirap) wrote :

No objection from me.. :)

Njira Perci (njirap) on 2016-02-22
Changed in openstack-manuals:
assignee: nobody → Njira Perci (njirap)
Njira Perci (njirap) on 2016-02-24
affects: openstack-manuals → openstack-doc-tools
Changed in openstack-doc-tools:
milestone: mitaka → none
Changed in openstack-manuals:
status: New → Confirmed
assignee: nobody → Njira Perci (njirap)
milestone: none → mitaka
importance: Undecided → Wishlist
Changed in openstack-doc-tools:
status: Confirmed → In Progress
Changed in openstack-manuals:
milestone: mitaka → newton
Lana (loquacity) wrote :

Njira: are you still working on this? Thanks, Lana

Hi Lana. Yes I am setting up the tests to work in tox..

On Sat, Apr 23, 2016 at 6:55 PM, Lana <email address hidden> wrote:

> Njira: are you still working on this? Thanks, Lana
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/1387716
>
> Title:
> os-doc-tools doesn't have unit tests
>
> Status in openstack-doc-tools:
> In Progress
> Status in openstack-manuals:
> Confirmed
>
> Bug description:
> We have no tests at all on this package, and sometimes things break on
> less tested scripts. The python3 port will probably be easier with
> unit tests at hand too.
>
> We mostly manipulate text so these tests shouldn't be too complex to
> write, we just need to find time to write them :)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/openstack-doc-tools/+bug/1387716/+subscriptions
>

Changed in openstack-doc-tools:
assignee: Njira Perci (njirap) → Christian Berendt (berendt)
Changed in openstack-doc-tools:
assignee: Christian Berendt (berendt) → Njira Perci (njirap)
Changed in openstack-doc-tools:
assignee: Njira Perci (njirap) → Andreas Jaeger (jaegerandi)
Changed in openstack-doc-tools:
assignee: Andreas Jaeger (jaegerandi) → Njira Perci (njirap)

Reviewed: https://review.openstack.org/284122
Committed: https://git.openstack.org/cgit/openstack/openstack-doc-tools/commit/?id=c050836a8f6a688a9477d3da1dd775e2fd376428
Submitter: Jenkins
Branch: master

commit c050836a8f6a688a9477d3da1dd775e2fd376428
Author: Percila <email address hidden>
Date: Wed Feb 24 16:17:45 2016 +0300

    doc-tools unit tests

    Renamed sitemap file to avoid module name conflict
    when importing at the sitemap unittest

    Added py.test tox environment

    Change-Id: I94480e374b29802414b62591a51c04ecd804905e
    Closes-Bug: #1387716

Changed in openstack-doc-tools:
status: In Progress → Fix Released
Njira Perci (njirap) on 2016-08-04
Changed in openstack-manuals:
assignee: Njira Perci (njirap) → nobody

This issue was fixed in the openstack/openstack-doc-tools 1.0.0 release.

Changed in openstack-manuals:
assignee: nobody → Michael Glaser (mikeg451)
Changed in openstack-manuals:
assignee: Michael Glaser (mikeg451) → nobody
Abdus Salam (abduskhazi) on 2016-10-19
Changed in openstack-manuals:
assignee: nobody → Abdus Salam (abduskhazi)
Abdus Salam (abduskhazi) on 2016-10-19
Changed in openstack-manuals:
assignee: Abdus Salam (abduskhazi) → nobody
Changed in openstack-manuals:
milestone: newton → ocata
Lana (loquacity) on 2016-11-24
Changed in openstack-manuals:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers