in zed Cyborg master, openstack-tox-py36 zuul task failed

Bug #1977636 reported by Brin Zhang
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cyborg (OpenStack)
Fix Released
High
Brin Zhang

Bug Description

py36 start: getenv /home/zuul/src/opendev.org/openstack/cyborg/.tox/py36
py36 cannot reuse: no previous config /home/zuul/src/opendev.org/openstack/cyborg/.tox/py36/.tox-config1
py36 create: /home/zuul/src/opendev.org/openstack/cyborg/.tox/py36
setting PATH=/home/zuul/src/opendev.org/openstack/cyborg/.tox/py36/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin
[1617] /home/zuul/src/opendev.org/openstack/cyborg/.tox$ /home/zuul/.local/tox/bin/python3 -m virtualenv --no-download --python /home/zuul/.local/tox/bin/python3 py36
created virtual environment CPython3.6.9.final.0-64 in 571ms
  creator CPython3Posix(dest=/home/zuul/src/opendev.org/openstack/cyborg/.tox/py36, clear=False, no_vcs_ignore=False, global=False)
  seeder FromAppData(download=False, pip=bundle, setuptools=bundle, wheel=bundle, via=copy, app_data_dir=/home/zuul/.local/share/virtualenv)
    added seed packages: pip==21.3.1, setuptools==59.6.0, wheel==0.37.1
  activators BashActivator,CShellActivator,FishActivator,NushellActivator,PowerShellActivator,PythonActivator
py36 installdeps: -c/home/zuul/src/opendev.org/openstack/requirements/upper-constraints.txt, -r/home/zuul/src/opendev.org/openstack/cyborg/requirements.txt, -r/home/zuul/src/opendev.org/openstack/cyborg/test-requirements.txt
setting PATH=/home/zuul/src/opendev.org/openstack/cyborg/.tox/py36/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin
[1631] /home/zuul/src/opendev.org/openstack/cyborg$ /home/zuul/src/opendev.org/openstack/cyborg/.tox/py36/bin/python -m pip install -c/home/zuul/src/opendev.org/openstack/requirements/upper-constraints.txt -r/home/zuul/src/opendev.org/openstack/cyborg/requirements.txt -r/home/zuul/src/opendev.org/openstack/cyborg/test-requirements.txt
Looking in indexes: https://mirror-int.ord.rax.opendev.org/pypi/simple, https://mirror-int.ord.rax.opendev.org/wheel/ubuntu-18.04-x86_64
Collecting pbr!=2.1.0,>=0.11
  Downloading https://mirror-int.ord.rax.opendev.org/wheel/ubuntu-18.04-x86_64/pbr/pbr-5.9.0-py2.py3-none-any.whl (112 kB)
Collecting pecan!=1.0.2,!=1.0.3,!=1.0.4,!=1.2,>=1.0.0
  Downloading https://mirror-int.ord.rax.opendev.org/wheel/ubuntu-18.04-x86_64/pecan/pecan-1.4.1-py3-none-any.whl (147 kB)
Collecting WSME>=0.10.1
  Downloading https://mirror-int.ord.rax.opendev.org/pypifiles/packages/d2/a0/54b71fd2e1ab4f838acf472726a14dadb6d1c77adc18d7e2c062dd955ff9/WSME-0.11.0-py3-none-any.whl (59 kB)
Collecting eventlet>=0.26.0
  Downloading https://mirror-int.ord.rax.opendev.org/pypifiles/packages/20/c0/b8796b6b965f9804b72baccc64b621241736cad7d5f6028ca7bcd0543b8f/eventlet-0.33.1-py2.py3-none-any.whl (226 kB)
Collecting oslo.i18n>=1.5.0
  Downloading https://mirror-int.ord.rax.opendev.org/pypifiles/packages/0d/78/d4079dc5a6adc19e91ed3f62af3061a3e3be2d4de12fdd802db38ceaeec1/oslo.i18n-5.1.0-py3-none-any.whl (46 kB)
Collecting oslo.config!=4.3.0,!=4.4.0,>=1.1.0
  Downloading https://mirror-int.ord.rax.opendev.org/pypifiles/packages/c5/4c/6cfd9274f3fb665f276ec41bd7c98fce20d5ec903bac7b4cd2c30f5832fe/oslo.config-8.8.0-py3-none-any.whl (128 kB)
ERROR: Cannot install oslo.log>=1.14.0 because these package versions have conflicting dependencies.

The conflict is caused by:
    The user requested oslo.log>=1.14.0
    The user requested (constraint) oslo-log===5.0.0

To fix this you could try to:
1. loosen the range of package versions you've specified
2. remove package versions to allow pip attempt to solve the dependency conflict

ERROR: ResolutionImpossible: for help visit https://pip.pypa.io/en/latest/user_guide/#fixing-conflicting-dependencies
ERROR: invocation failed (exit code 1)
ERROR: could not install deps [-c/home/zuul/src/opendev.org/openstack/requirements/upper-constraints.txt, -r/home/zuul/src/opendev.org/openstack/cyborg/requirements.txt, -r/home/zuul/src/opendev.org/openstack/cyborg/test-requirements.txt]; v = InvocationError('/home/zuul/src/opendev.org/openstack/cyborg/.tox/py36/bin/python -m pip install -c/home/zuul/src/opendev.org/openstack/requirements/upper-constraints.txt -r/home/zuul/src/opendev.org/openstack/cyborg/requirements.txt -r/home/zuul/src/opendev.org/openstack/cyborg/test-requirements.txt', 1)
py36 finish: getenv /home/zuul/src/opendev.org/openstack/cyborg/.tox/py36 after 3.95 seconds
___________________________________ summary ____________________________________
ERROR: py36: could not install deps [-c/home/zuul/src/opendev.org/openstack/requirements/upper-constraints.txt, -r/home/zuul/src/opendev.org/openstack/cyborg/requirements.txt, -r/home/zuul/src/opendev.org/openstack/cyborg/test-requirements.txt]; v = InvocationError('/home/zuul/src/opendev.org/openstack/cyborg/.tox/py36/bin/python -m pip install -c/home/zuul/src/opendev.org/openstack/requirements/upper-constraints.txt -r/home/zuul/src/opendev.org/openstack/cyborg/requirements.txt -r/home/zuul/src/opendev.org/openstack/cyborg/test-requirements.txt', 1)

Brin Zhang (zhangbailin)
Changed in openstack-cyborg:
importance: Undecided → High
assignee: nobody → Brin Zhang (zhangbailin)
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to cyborg (master)

Fix proposed to branch: master
Review: https://review.opendev.org/c/openstack/cyborg/+/844670

Changed in openstack-cyborg:
status: New → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to cyborg (master)

Reviewed: https://review.opendev.org/c/openstack/cyborg/+/844670
Committed: https://opendev.org/openstack/cyborg/commit/68c558645c922dbef8f8b0f08fb950f9f11e6228
Submitter: "Zuul (22348)"
Branch: master

commit 68c558645c922dbef8f8b0f08fb950f9f11e6228
Author: zhangbailin <email address hidden>
Date: Sat Jun 4 14:10:03 2022 +0800

    Drop py3.6 and py3.7 from Cyborg

    In zed cycle, OpenStack projects and oslo lib
    has dropped the py3.6 and py3.7 support

    - https://governance.openstack.org/tc/reference/runtimes/zed.html

    With oslo not supporting the py3.6 and py3.7, we disscussed in cyborg
    team, and we will remove the py3.6 and py3.7 support too.

    Closes-Bug: #1977636
    Change-Id: Ib934e50ee6e89cb1e2b4cbf8390eee2baa30effd

Changed in openstack-cyborg:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/cyborg 9.0.0.0rc1

This issue was fixed in the openstack/cyborg 9.0.0.0rc1 release candidate.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers