ask.openstack profile photo is not functional

Bug #1441398 reported by Omar Munoz on 2015-04-08
50
This bug affects 11 people
Affects Status Importance Assigned to Milestone
OpenStack Community Project
Medium
Evgeny Fadeev
OpenStack Core Infrastructure
New
Undecided
Unassigned

Bug Description

ask.openstack doesn't allow you to modify/add profile photo 'change picture' button redirects to FAQ

*Steps to replicate*
1- log into ask.openstack.org
2- navigate to your personal profile - 'overview' tab
3- Attempt to upload a photo or 'change picture' and it will redirect you to https://ask.openstack.org/en/faq/#gravatar

https://ask.openstack.org/en/question/64674/many-pictures-get-lost-after-upgrade-and-change-picture-link-doesnt-work/
https://ask.openstack.org/en/question/64676/bug-under-profile-on-askopenstackorg/

Omar Munoz (omar-munoz) wrote :
Stefano Maffulli (smaffulli) wrote :

From an IRC chat:

       <fungi> reed: i'm wondering if something changed with the theme. i don't see any clues in the apache error log and the avatar files look like they have the permissions i would expect (including all parent directories). also i can see my avatar when i go to my profile, just not on question pages

This needs more investigation.

Changed in openstack-community:
importance: Undecided → High
status: New → Confirmed
assignee: nobody → Evgeny Fadeev (evgeny-fadeev)
Stefano Maffulli (smaffulli) wrote :

Spoke with Evgeny, he says:

  "django-avatar lib is likely not installed. At this point better to wait till the upgrade because up to recently avatar library was not from the release. Now there is a new released avatar app and support for it built into askbot"

tags: removed: mailinglist website
Stephen Gordon (sgordon) wrote :

FWIW it also seems to have dropped at least some user graphics. I had a profile photo, and have done since basically the day I joined the site, but noticed today that (a) it's gone (b) I can't add one.

Tom Fifield (fifieldt) on 2015-06-23
Changed in openstack-community:
importance: High → Medium
Vincent Legoll (vincent-legoll) wrote :

Is there an ETA for the site upgrade ?

Tom Fifield (fifieldt) wrote :

I haven't heard anything. Probably need to email http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-infra

Stefano Maffulli (smaffulli) wrote :

The site has been upgraded months ago so if there are still issues, these are due to something else entirely and this bug requires further investigation.

Tom Fifield (fifieldt) wrote :

I cannot find an ubuntu package for django-avatar.

jtaguinerd (joannaliza) wrote :

I noticed that profile photo is still not functioning. Mine is gone and I can not add one.

Vikram Hosakote (vhosakot) wrote :

I'm not able to upload my profile photo as well in https://ask.openstack.org. It keeps going to the FAQ page https://ask.openstack.org/en/faq/#gravatar when I click on "Change picture". Any idea when this bug will be fixed. I have a cool pic I want to upload :)

Vern Hart (vhart) wrote :

This bug perplexes me. It's not difficult to resolve as it's just a FAQ entry. If I knew how to create a FAQ, I'd fix it already.

The ask.openstack.org site uses gravatar to obtain profile pictures.

To add or change your profile picture, visit gravatar.com and create an account using the same email address that is listed on your profile. After you've done this, make sure you've clicked the confirm link the the email gravatar sends you. The confirmation email will actually come from wordpress.com, not gravatar. Then upload your picture.

If you already have a gravatar account, you can add multiple email addresses.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers