Severe markdown rendering problems on ask.openstack.org

Bug #1271200 reported by Lars Kellogg-Stedman on 2014-01-21
42
This bug affects 10 people
Affects Status Importance Assigned to Milestone
OpenStack Community Project
Medium
Evgeny Fadeev

Bug Description

There are significant differences between the Markdown processor used to render the preview of a question and the Markdown processor used to actually render the question after it has been saved. Please see the following question for a demonstration:

https://ask.openstack.org/en/question/10771/there-are-markdown-rendering-problems-with-askopenstackorg/

This can lead to poorly rendered questions and can even prevent questions from displaying completely. The fact that these problems do not show up in the preview is especially frustrating.

tags: added: askbot
Changed in openstack-community:
assignee: nobody → Evgeny Fadeev (evgeny-fadeev)
Lars Kellogg-Stedman (larsks) wrote :

Attached is a screenshot of the problem in which questions and answers do not display in their entirety.

Stefano Maffulli (smaffulli) wrote :

That is so strange: I have edited the question and the answers on https://ask.openstack.org/en/question/6540/migration-from-essex-to-havana/ and the ... disappeared. Now I can see the full questions and answers on my browsers (tried Firefox, Firefox private mode, Chromium and Chromium incognito).

Changed in openstack-community:
importance: Undecided → High
tags: added: askproject
removed: askbot
Evgeny Fadeev (evgeny-fadeev) wrote :

Mostly I think this is a duplicate of https://bugs.launchpad.net/openstack-community/+bug/1271040, now fixed.

However there is a difference between the previewer's display of the content and the rendered content, however this issue
is separate from the one linked above.

Lars Kellogg-Stedman (larsks) wrote :

In fact, whatever is rendering the content isn't just different, it's demonstrably broken. You can see that the rendered version of my sample post at https://ask.openstack.org/en/question/10771/there-are-markdown-rendering-problems-with-askopenstackorg/ is horribly corrupted.

Evgeny Fadeev (evgeny-fadeev) wrote :

Yes, this one looks really bad, I will try to resolve today.

Evgeny Fadeev (evgeny-fadeev) wrote :

Disabled the "autolinking", which was interfering with markdown. I will take a second look tomorrow.

Changed in openstack-community:
status: New → Confirmed
importance: High → Medium
Evgeny Fadeev (evgeny-fadeev) wrote :

I believe this is resolved now.

Changed in openstack-community:
status: Confirmed → Fix Released
Evgeny Fadeev (evgeny-fadeev) wrote :

There are other issues related to the difference between the markdown parser on the backend and in the previewer.

This will have to be a separate project to re-implement the js version to mimic the backend version precisely.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments