Dev docs sites for past releases of nova (2011.1) now 404 error

Bug #972724 reported by Anne Gentle on 2012-04-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Core Infrastructure
Fix Released
Medium
Clark Boylan

Bug Description

We used to keep a copy of past releases of nova.openstack.org, such as http://nova.openstack.org/2011.1, for future reference. I'm getting a 404 when visiting those URLs now - would like to find out root cause.

James E. Blair (corvus) on 2012-04-03
Changed in openstack-ci:
status: New → Confirmed
assignee: nobody → James E. Blair (corvus)
importance: Undecided → High
James E. Blair (corvus) wrote :

The apache configuration has:
        DocumentRoot /srv/docs/nova/doc/build/html/

        Alias /2011.2 /srv/docs/nova/2011.2

So it looks like at some point someone copied the main tree (/doc/build/html) to a sibling directory (2011.2) , and added the alias to the apache configuration. I added this to fix the immediate issue (since 2011.1 was still there):

        Alias /2011.1 /srv/docs/nova/2011.1

But this seems like an arbitrary and manual process. What is the current process for creating a new version of the docs (we should have 2012.1 now, right)?

Monty Taylor (mordred) wrote :

Moving forward, we have a whole system for generating docs from tags and giving them a subdir. 2011.1 was created before we moved to the tag system, so we should probably just copy it into the new docs site.

Changed in openstack-ci:
assignee: James E. Blair (corvus) → Clark Boylan (cboylan)
milestone: none → folsom
status: Confirmed → Triaged
importance: High → Medium
Anne Gentle (annegentle) wrote :

Something similar is going on with swift -

What's interesting is that I can get to http://docs.openstack.org/developer/swift/1.7.4/development_auth.html -- so it seems like this one would represent Folsom docs. Where are the Essex ones though?

Thanks for looking into it.

Monty Taylor (mordred) on 2012-10-10
Changed in openstack-ci:
milestone: folsom → grizzly
Clark Boylan (cboylan) wrote :

The current in tree documentation builds should on tag releases copy the docs to http://docs.openstack.org/developer/project/$VERSION. This will cover everything >= Folsom I believe. If we want the older stuff we will need to run the doc builds manually and feed Jenkins the appropriate information to make it build old versions.

Clark Boylan (cboylan) on 2013-04-23
Changed in openstack-ci:
milestone: grizzly → havana
Clark Boylan (cboylan) wrote :

We are publishing docs to http://docs.openstack.org/developer/project/$VERSION for everything >= Folsom. We have deprecated the stable branches older than Folsom so will not be publishing docs from these versions to docs.openstack.org/developer.

Changed in openstack-ci:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers