rspec-system is not installable by gate-puppet-ceph-puppet-unit-*

Bug #1290710 reported by Loic Dachary on 2014-03-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Core Infrastructure
Invalid
Undecided
Unassigned

Bug Description

gate-puppet-ceph-puppet-unit-2.7 fails like so http://logs.openstack.org/31/64331/3/check/gate-puppet-ceph-puppet-unit-2.7/4bc862e/console.html sometime and sometimes does not (could it be that it depends on the node on which it runs ?).

<pre>
2014-03-10 20:10:44.928 | + GEM_HOME=/home/jenkins/workspace/gate-puppet-ceph-puppet-unit-2.7/.bundled_gems
2014-03-10 20:10:44.928 | + bundle install
2014-03-10 20:10:45.216 | Fetching https://git.gitorious.org/rspec-system/rspec-system.git
2014-03-10 20:10:54.282 | Fetching gem metadata from https://rubygems.org/.........
2014-03-10 20:10:54.460 | Fetching additional metadata from https://rubygems.org/..
2014-03-10 20:10:54.687 | Resolving dependencies...
2014-03-10 20:10:54.723 | Using rake (10.1.1)
2014-03-10 20:10:55.796 | Installing builder (3.2.2)
2014-03-10 20:10:55.797 | Using diff-lcs (1.2.5)
2014-03-10 20:10:57.093 | Installing excon (0.31.0)
2014-03-10 20:10:57.762 | Installing facter (1.7.5)
2014-03-10 20:10:58.202 | Installing formatador (0.2.4)
2014-03-10 20:10:59.105 | Installing mime-types (1.25.1)
2014-03-10 20:10:59.606 | Installing multi_json (1.9.0)
2014-03-10 20:11:00.827 | Installing net-ssh (2.8.0)
2014-03-10 20:11:01.290 | Installing net-scp (1.1.2)
2014-03-10 20:11:02.720 |
2014-03-10 20:11:02.720 | Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension.
2014-03-10 20:11:02.721 |
2014-03-10 20:11:02.721 | /usr/bin/ruby1.8 extconf.rb
2014-03-10 20:11:02.721 | extconf.rb:5:in `require': no such file to load -- mkmf (LoadError)
2014-03-10 20:11:02.721 | from extconf.rb:5
2014-03-10 20:11:02.721 |
2014-03-10 20:11:02.721 |
2014-03-10 20:11:02.721 | Gem files will remain installed in /home/jenkins/workspace/gate-puppet-ceph-puppet-unit-2.7/.bundled_gems/gems/nokogiri-1.5.11 for inspection.
2014-03-10 20:11:02.721 | Results logged to /home/jenkins/workspace/gate-puppet-ceph-puppet-unit-2.7/.bundled_gems/gems/nokogiri-1.5.11/ext/nokogiri/gem_make.out
2014-03-10 20:11:02.758 | An error occurred while installing nokogiri (1.5.11), and Bundler cannot
2014-03-10 20:11:02.758 | continue.
2014-03-10 20:11:02.759 | Make sure that `gem install nokogiri -v '1.5.11'` succeeds before bundling.
2014-03-10 20:11:02.954 | Build step 'Execute shell' marked build as failure
</pre>

Loic Dachary (dachary) wrote :

http://irc-logs.puppetlabs.com/puppet/%23puppet-2013-09-25.log.html
<pre>
[2013/09/25 05:09:02] <n1tr0g> gem install rspec-system
[2013/09/25 05:09:03] <n1tr0g> ERROR: Error installing rspec-system:
[2013/09/25 05:09:03] <n1tr0g> nokogiri requires Ruby version >= 1.9.2.
[2013/09/25 05:09:07] <_rc> bundler resolves the ruby gems so 1.8 doesn't need to
[2013/09/25 05:09:18] <n1tr0g> hmmm but that is a requirement from the Rakefile of puppetlabs-mysql
[2013/09/25 05:09:38] <_rc> so bundle install --without development
[2013/09/25 05:09:52] <_rc> you can run just the rspec-puppet tests
</pre>

Loic Dachary (dachary) on 2014-03-11
summary: - `require': no such file to load -- mkmf (LoadError)
+ rspec-system is not installable by gate-puppet-ceph-puppet-unit-*
Loic Dachary (dachary) wrote :

It is unclear how it can be fixed because jenkins slave cannot accomodate all modules that can be found in the Gemfile. And it is probably overkill to try to when only a subset of them is going to be used for testing anyway. For puppet-ceph it was fixed with https://review.openstack.org/#/c/79557/

Changed in openstack-ci:
status: New → Invalid
Jeremy Stanley (fungi) wrote :

Right, I think this is probably not really a bug in the infrastructure configuration in this case, and your solution looks like it could be applicable for other projects in similar situations so it's great to have it documented as a workaround. We also have some changes going in which will allow jobs that absolutely require elevated privileges to use sudo, since we now no longer reuse any of the servers where these tests run and there's no chance for one job to inadvertently (or intentionally for that matter) corrupt the workspace for another job.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers