UniversalLanguageSelector breaks wiki skin

Bug #1254911 reported by Stefano Maffulli on 2013-11-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Core Infrastructure
Fix Released
Medium
Jeremy Stanley

Bug Description

While testing the TranslateWiki extension we realized that the UniversalLanguageSelector breaks the skin. Translations of the wiki pages are not possible until the skin is fixed.

James E. Blair (corvus) on 2013-12-10
Changed in openstack-ci:
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Ryan Lane (rlane)
Stefano Maffulli (smaffulli) wrote :

I think this needs to be higher priority, or fixed more rapidly. The i18n team is translating pages without it and it may be frustrating people this way. There may be other people who can help fix the CSS/JS issues but I couldn't find the repository where the wiki's skin is kept. Ryan: maybe you can just give some pointers, I'll try to find someone who can fix the actual skin.

Ryan Lane (rlane) wrote :

This is the skin we're using:

https://github.com/OSAS/strapping-mediawiki

Upstreaming the changes would be good. I'm pretty sure I won't get time for this in the near future, so if you can find someone to fix it, it's likely a good idea.

Changed in openstack-ci:
assignee: Ryan Lane (rlane) → nobody
Stefano Maffulli (smaffulli) wrote :

Taken with Firefox on Ubuntu

Stefano Maffulli (smaffulli) wrote :

There is a fix for this issue proposed upstream: https://gerrit.wikimedia.org/r/#/c/163187/

git fetch https://gerrit.wikimedia.org/r/mediawiki/extensions/Translate refs/changes/87/163187/2 && git cherry-pick FETCH_HEAD

Stefano Maffulli (smaffulli) wrote :

fixed upstream on MediaWiki Language Extension
Bundle 2014.09 https://lists.wikimedia.org/pipermail/mediawiki-i18n/2014-September/000920.html

Jeremy Stanley (fungi) wrote :

I have upgraded Mediawiki and all installed extensions on wiki.openstack.org. Can you check to see if this is working as intended now?

Changed in openstack-ci:
assignee: nobody → Jeremy Stanley (fungi)
milestone: none → juno
status: Triaged → In Progress
Stefano Maffulli (smaffulli) wrote :

Well... the integration with Launchpad broke during the upgrade. When trying to login I get redirected to https://wiki.openstack.org/w/index.php?title=Special:OpenIDLogin&returnto=Special:Translate which shows way too many options.

Stefano Maffulli (smaffulli) wrote :

Issue solved, thank you Jeremy and Nikerabbit Niklas Laxström for fixing the issue upstream.

Tested on https://wiki.openstack.org/wiki/Category:Programs/it

Changed in openstack-ci:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers