puppet-dashboard does not run background services

Bug #1219076 reported by Robert Collins on 2013-08-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Core Infrastructure
Won't Fix
Low
Aaron Greengrass

Bug Description

You end up with '/!\ 46 pending tasks'

Robert Collins (lifeless) wrote :

A freshly puppetised dashboard has at least the following issues:
 - puppet-dashboard-workers won't start
 - because /etc/default/puppet-dashboard doesn't exist

I can add a service definition for puppet-dashboard-workers, but I don't know what the missing file should look like :).

Robert Collins (lifeless) wrote :

the puppet-dashboard package contains a /etc/default/puppet-dashboard file so it seems like we're probably deleting it ourselves. I'll wait for someone familiar with the history of the dashboard setup to comment before I dig into this.

Clark Boylan (cboylan) wrote :

Anteaya is working on completely overhauling our puppet dashboard stuff to fix the various problems we have had with the existing manifests. Those changes should include a fix for making sure the workers run.

Changed in openstack-ci:
status: New → Triaged
importance: Undecided → Low
assignee: nobody → Anita Kuno (anteaya)
milestone: none → icehouse
Anita Kuno (anteaya) on 2013-12-13
Changed in openstack-ci:
assignee: Anita Kuno (anteaya) → nobody
Changed in openstack-ci:
assignee: nobody → Aaron Greengrass (aaron-t)
Clark Boylan (cboylan) wrote :

We are moving to use puppetboard at all available speed.

Changed in openstack-ci:
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers