nova API version doc should point to Nova developer doc

Bug #1093812 reported by koolhead17 on 2012-12-26
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Undecided
Unassigned
OpenStack Core Infrastructure
Confirmed
High
Unassigned

Bug Description

Currently nova.openstack.org redirects to docs.openstack.org/developer/nova.
But the /versionnumber sites (http://nova.openstack.org/2011.2 ), points 404.

Can we get this fixed?

Tom Fifield (fifieldt) on 2012-12-27
tags: added: doc-builds
Changed in openstack-manuals:
status: New → Confirmed
importance: Undecided → High
Anne Gentle (annegentle) on 2013-01-21
affects: openstack-manuals → openstack-ci
Anita Kuno (anteaya) on 2013-02-19
Changed in openstack-ci:
status: Confirmed → Invalid
Anita Kuno (anteaya) wrote :

I talked to koolhead17 in irc and he says the bug no longer exists.

I only have the ability to close bugs by marking them invalid, which I have done. If someone else wants to change the bug status to closed, please do so.

Anita Kuno (anteaya) wrote :

Bug still exists.

To replicate, go to: http://docs.openstack.org/developer/nova/object.model.html
In the right hand navigation close to the bottom you will see a link "Nova 2011.2 docs",
clicking the link (http://nova.openstack.org/2011.2) returns 404, page not found.

Anne Gentle will make a decision after the summit how she wants bugs like this one, there are a few, handled going forward. Until that time, we don't have a way to fix the individual bugs. We need a process to fix them all.

Changed in openstack-ci:
status: Invalid → Confirmed
Clark Boylan (cboylan) on 2013-04-23
Changed in openstack-ci:
milestone: none → havana
Clark Boylan (cboylan) wrote :

These docs are built out of the Nova tree. Adding this as a Nova bug as it will need to be fixed in Nova.

Ben Nemec (bnemec) wrote :

Confirming for Nova based on the fact that I see the broken link and Clark's comment that this needs to be fixed in Nova.

Changed in nova:
status: New → Confirmed
Clark Boylan (cboylan) on 2013-10-22
Changed in openstack-ci:
milestone: havana → icehouse
Anita Kuno (anteaya) wrote :

This bug still exists. Following my instructions for replication in comment #2 results in a 404 response.

Sean Dague (sdague) wrote :

The issue is actually that the url in question is *not* built out of the Nova tree, it's dead orphaned content that needs to be deleted manually by infra.

Changed in nova:
status: Confirmed → Invalid
Jeremy Stanley (fungi) on 2014-10-27
Changed in openstack-ci:
milestone: icehouse → kilo
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers