Add grenade-based upgrade testing

Bug #1082794 reported by Monty Taylor on 2012-11-25
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenStack Core Infrastructure
Fix Released
High
Sean Dague
grenade
Undecided
Sean Dague

Bug Description

The devstack folks have written grenade, which is a devstack-based upgrade testing suite. We should get it integrated and then start gating on upgradability.

James E. Blair (corvus) on 2013-04-23
Changed in openstack-ci:
milestone: grizzly → havana
James E. Blair (corvus) wrote :

This is ready to go; we're just waiting on the okay from Sean to enable gating.

Changed in openstack-ci:
assignee: James E. Blair (corvus) → Sean Dague (sdague)
James E. Blair (corvus) wrote :

We're gating on master (yay!), we should add the symmetric gating on stable/grizzly before closing this.

Clark Boylan (cboylan) wrote :

From a bug marked as a duplicate of this bug.

If someone proposes a change to a stable branch that grenade tests, we
should test the upgrade _from_ that branch to the release.

https://etherpad.openstack.org/havana-upgrade-testing

Clark Boylan (cboylan) on 2013-10-22
Changed in openstack-ci:
milestone: havana → icehouse
Jeremy Stanley (fungi) wrote :
Changed in grenade:
assignee: nobody → Sean Dague (sdague)
Clark Boylan (cboylan) wrote :

gate-grenade-dsvm-forward is an experimental job. Once that job is gating this bug can be closed.

Sean Dague (sdague) wrote :

I think we should make forward a separate thing to track, as this bug just keeps growing scope over time

Changed in grenade:
status: New → Fix Released
Changed in openstack-ci:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers