[identity] in-process token cache is deprecated in favor of memcache

Bug #1661753 reported by Samuel Cassiba on 2017-02-03
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenStack + Chef
Medium
Dr. Jens Harbott

Bug Description

2017-02-03 21:58:42.861 24305 WARNING keystonemiddleware.auth_token [-] Using the in-process token cache is deprecated as of the 4.2.0 release and may be removed in the 5.0.0 release or the 'O' development cycle. The in-process cache causes inconsistent results and high memory usage. When the feature is removed the auth_token middleware will not cache tokens by default which may result in performance issues. It is recommended to use memcache for the auth_token token cache by setting the memcached_servers option.

Changed in openstack-chef:
status: New → Confirmed
Dr. Jens Harbott (j-harbott) wrote :

The solution seems to be to add

[keystone_authtoken]
memcached_servers = ...

entries into the configs for all affected services:

# grep keystone_authtoken /etc/*/*.conf
/etc/ceilometer/ceilometer.conf:[keystone_authtoken]
/etc/cinder/cinder.conf:[keystone_authtoken]
/etc/glance/glance-api.conf:[keystone_authtoken]
/etc/glance/glance-registry.conf:[keystone_authtoken]
/etc/heat/heat.conf:[keystone_authtoken]
/etc/murano/murano.conf:[keystone_authtoken]
/etc/neutron/neutron.conf:[keystone_authtoken]
/etc/nova/nova.conf:[keystone_authtoken]

I'll spin up a set of patches once https://review.openstack.org/431528 is merged which fixes setting memcached_servers in the integration test.

Changed in openstack-chef:
status: Confirmed → In Progress
assignee: nobody → Dr. Jens Rosenboom (j-rosenboom-j)
Changed in openstack-chef:
importance: Undecided → Medium
Roger Luethi (rl-o) wrote :

The warning message has not changed in Pike. It still suggests that the in-process token cache may be removed for Ocata. So we're good at least until Queens.

Changed in openstack-chef:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers