[openstack-chef-repo] aio-nova, missing eth0 MASQUERADE

Bug #1463016 reported by Petr Michalec on 2015-06-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack + Chef
Wishlist
Unassigned

Bug Description

when aio deployed (in my case to existing VM over ssh) the VM's created in the openstack do not route to the internet. They can sucessfully resolve IP over DNS servise on controller node. Hover ping/wget are not working.

A way to make it runnig is:

sudo iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

I am aware of the fact that this goes from the individual attributes of the urser environment. Feel free to close bug if you assume this an offtopic.

However would be fine to mention it in docs, add tests for deployed VM whether it can reach public internet, consider circumstances and intentionally run such command during provisioning of the controller node as example vagrant-aio-nova creates only a private network that must be somehow NATed to external world.

Mark Vanderwiel (vanderwl) wrote :

I think this would be a nice addition to the repo doc tree, please consider making a patch for this.

Changed in openstack-chef:
status: New → Triaged
importance: Undecided → Wishlist
Petr Michalec (epcim) wrote :

Ok, I plan deploy one more environment, so will create some notes worth to upload to documentation.

tags: added: repo
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers