[compute] anytime the libvirt driver is used in nova, libguestfs should also be installed

Bug #1462102 reported by Matt Riedemann on 2015-06-04
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenStack + Chef
Medium
Mark Vanderwiel

Bug Description

There was a gate blocker for openstack back in icehouse (bug 1273386) due to a kernel bug in ubuntu 12.04 where if you're using nbd and network namespaces (with neutron), you can cause a kernel panic when booting an instance with nova.

The fix included changes to devstack to install libguestfs (python-libguestfs on RHEL/Fedora/CentOS/SuSE, libguestfs0 and python-guestfs on Debian/Ubuntu), you can see that in devstack here:

https://github.com/openstack-dev/devstack/blob/master/lib/nova_plugins/functions-libvirt#L23

This needs to also be in the chef cookbooks so people don't run into the same issues.

Also, nbd kind of sucks so using libguestfs in nova is preferable anyway.

tags: added: compute
Matt Riedemann (mriedem) on 2015-06-04
tags: added: icehouse-backport-potential juno-backport-potential kilo-backport-potential
removed: compute
Mark Vanderwiel (vanderwl) wrote :

on ubuntu 14.04, looks like python-guestfs depends upon libguestfs0, so would only need python-guestfs in the package list.

Changed in openstack-chef:
importance: Undecided → Medium
status: New → Confirmed
assignee: nobody → Mark Vanderwiel (vanderwl)
milestone: none → kilo-rc1

Fix proposed to branch: master
Review: https://review.openstack.org/188598

Changed in openstack-chef:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/188598
Committed: https://git.openstack.org/cgit/stackforge/cookbook-openstack-compute/commit/?id=0890f052aed71bcd3b6d59c1530c2de538f0297c
Submitter: Jenkins
Branch: master

commit 0890f052aed71bcd3b6d59c1530c2de538f0297c
Author: Mark Vanderwiel <email address hidden>
Date: Thu Jun 4 16:30:28 2015 -0500

    Add guestfs packages for libvirt support

    libvirt can use the guestfs support and it is preferred by nova.

    Change-Id: I76fc9f6b311b3023a1ef3ea079e3c4c8cff6582b
    Closes-Bug: #1462102

Changed in openstack-chef:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers