[network] /etc/neutron/services/neutron-fwaas does not exist

Bug #1438292 reported by Mark Vanderwiel on 2015-03-30
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenStack + Chef
High
Mark Vanderwiel

Bug Description

                 ←[0m * template[/etc/neutron/services/neutron-fwaas/fwaas_driver.ini] action create[2015-03-30T15:38:23+00:00] INFO: Processing temp
late[/etc/neutron/services/neutron-fwaas/fwaas_driver.ini] action create (openstack-network::l3_agent line 111)

                     * Parent directory /etc/neutron/services/neutron-fwaas does not exist.
                     ================================================================================
                     Error executing action `create` on resource 'template[/etc/neutron/services/neutron-fwaas/fwaas_driver.ini]'
                     ================================================================================

                 ←[0m Chef::Exceptions::EnclosingDirectoryDoesNotExist
                     ------------------------------------------------
                     Parent directory /etc/neutron/services/neutron-fwaas does not exist.

Looks at the /etc/neutron on ubuntu 14 with kilo, I see the following:

root@controller:/etc/neutron# ls -la
total 68
drwxr-x--- 5 root neutron 4096 Mar 30 15:36 .
drwxr-xr-x 104 root root 4096 Mar 30 15:36 ..
-rw-r----- 1 neutron neutron 1117 Mar 30 15:31 api-paste.ini
-rw-r--r-- 1 root neutron 109 Dec 18 14:23 fwaas_driver.ini
-rw-r----- 1 neutron neutron 3881 Mar 30 15:36 l3_agent.ini
-rw-r--r-- 1 root root 2058 Dec 18 14:23 metadata_agent.ini
-rw-r----- 1 neutron neutron 18624 Mar 30 15:31 neutron.conf
drwx------ 3 neutron neutron 4096 Mar 30 15:31 plugins
drwxr-xr-x 2 root neutron 4096 Feb 2 14:03 policy.d
-rw-r--r-- 1 root neutron 6343 Dec 18 14:23 policy.json
-rw-r--r-- 1 neutron neutron 1244 Mar 30 15:31 rootwrap.conf
drwxr-xr-x 2 root root 4096 Mar 30 15:35 rootwrap.d
root@controller:/etc/neutron# cat fwaas_driver.ini
[fwaas]
#driver = neutron.services.firewall.drivers.linux.iptables_fwaas.IptablesFwaasDriver
#enabled = True

Notice the fwaas_driver.ini is in the /etc/neutron directory, installed as part of the packages.

So, where should this file be on ubuntu kilo?

1) /etc/neturon
or
2) /etc/neutron/services/neutron-fwaas

from this comment, https://openstack.nimeyo.com/38420/openstack-dev-packaging-neutron-config-dir-vs-config-file, it appears that RDO also uses the /etc/neutron path.

And this wiki also shows it, https://wiki.openstack.org/wiki/Neutron/FWaaS/HowToInstall

Also confirmed the contents of the /etc/init/neutron-l3-agent.conf

exec start-stop-daemon --start --chuid neutron --exec /usr/bin/neutron-l3-agent -- \
  --config-file=/etc/neutron/neutron.conf --config-file=/etc/neutron/l3_agent.ini \
  --config-file=/etc/neutron/fwaas_driver.ini --log-file=/var/log/neutron/l3-agent.log

Mark Vanderwiel (vanderwl) wrote :

Related patch: https://review.openstack.org/#/c/163688/10

Song Li, can you verify why use use this /etc/neutron/services/neutron-fwaas path? It looks like the wrong path for both ubuntu and rdo, they both use /etc/neutron.

Mark Vanderwiel (vanderwl) wrote :

John, any thoughts on this one?

Mark Vanderwiel (vanderwl) wrote :

Looks like this might also apply to vnpaas and lbaas.

Wei Hu (huwei-xtu) wrote :

I notice the file path is hard code(https://github.com/stackforge/cookbook-openstack-network/blob/master/recipes/l3_agent.rb#L111). What about change this value to an attribute ? So that this recipe also can work with those configuration files locate in different directory.

Mark Vanderwiel (vanderwl) wrote :

Yes, an attribute would be fine here.

Song Li (lisong-cruise) wrote :

Yes, I think add attribute is a flexible way. Maybe I can add the attribute for the path to make them flexible in bug 1438148

John Kasperski (jckasper) wrote :

fwaas, vpnaas, and lbaas were all moved out of the base neutron community code into separate repos in Kilo. The path change for these configuration files is probably a result of this move. All of this distros may not have not been updated for this path change yet.

Mark Vanderwiel (vanderwl) wrote :

Fixed released with patch: https://review.openstack.org/#/c/169275/

Changed in openstack-chef:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers