[block-storage] lvm2 package missing

Bug #1435968 reported by Mark Vanderwiel on 2015-03-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack + Chef
High
Ma Wen Cheng

Bug Description

The openstack cinder package used to be dependent upon lvm2, but that has now changed and in some repo, the lvm2 package in not installed. The cookbook uses the vgcreate command in the LVMISCSIDriver case here: https://github.com/stackforge/cookbook-openstack-block-storage/blob/master/recipes/volume.rb#L166

Need to make sure that the lvm2 package is installed. It has the "lvm2" package name for ubuntu, rhel, and suse platforms.

Fix proposed to branch: master
Review: https://review.openstack.org/167321

Changed in openstack-chef:
status: New → In Progress
Changed in openstack-chef:
assignee: Mark Vanderwiel (vanderwl) → Ma Wen Cheng (mars914)

Reviewed: https://review.openstack.org/167321
Committed: https://git.openstack.org/cgit/stackforge/cookbook-openstack-block-storage/commit/?id=98688befe1ff9fe7bbdbf89680584042b4268d7d
Submitter: Jenkins
Branch: master

commit 98688befe1ff9fe7bbdbf89680584042b4268d7d
Author: Mark Vanderwiel <email address hidden>
Date: Tue Mar 24 11:58:28 2015 -0500

    Make sure lvm2 package is installed

    lvm volume recipe makes use of lvm commands like vgcreate. These
    commands are part of the lvm2 package which may not be a
    dependency for the base openstack cinder packages anymore. So,
    make sure this get installed before using those commands.

    Change-Id: I75f47260677b409ff32c4b2c6fc5598a31214ecf
    Closes-Bug: #1435968

Changed in openstack-chef:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers