oslo.messaging.transport.InvalidTransportURL: No scheme specified in "None"

Bug #1429245 reported by Mark Vanderwiel on 2015-03-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack + Chef
Critical
Ma Wen Cheng

Bug Description

oslo.messaging.transport.InvalidTransportURL: No scheme specified in "None"

ironic-dbsync --config-file /etc/ironic/ironic.conf create_schema

reproduce with latest master, and using chef repo with aio_nova.

Changed in openstack-chef:
assignee: nobody → Ma Wen Cheng (mars914)
description: updated
Changed in openstack-chef:
status: New → In Progress
Ma Wen Cheng (mars914) wrote :

maybe it is also fixed in this patch : https://review.openstack.org/#/c/162003/

Mark Vanderwiel (vanderwl) wrote :

I reproduced this using the other patches, so something else is wrong with bare-metal.

Mark Vanderwiel (vanderwl) wrote :

I think I found the issue here: https://github.com/stackforge/cookbook-openstack-bare-metal/blob/master/templates/default/ironic.conf.erb#L202

No default set for ['openstack']['bare-metal']['rpc_backend']

Should be set to something like this instead? (as is done in image and other cookbooks?)

case node['openstack']['mq']['service_type']
when 'rabbitmq'
  default['openstack']['bare-metal']['rpc_backend'] = 'rabbit'
when 'qpid'
  default['openstack']['bare-metal']['rpc_backend'] = 'qpid'
end

Mark Vanderwiel (vanderwl) wrote :

The other issue is the hardcoded "create schema" on the api recipe:
execute 'ironic db sync' do
  command 'ironic-dbsync --config-file /etc/ironic/ironic.conf create_schema'

This will fail on the second pass of a converge. It's would need to be changed to "upgrade".
From reading http://docs.openstack.org/developer/ironic/cmds/ironic-dbsync.html it would appear that "upgrade" is the right choice here.

Mark Vanderwiel (vanderwl) wrote :

And i think the permissions need to be adjusted: getting this: IOError: [Errno 13] Permission denied: '/var/log/ironic/ironic-dbsync.log'

Mark Vanderwiel (vanderwl) wrote :

Yup, had to remove these two lines to allow it to work: https://github.com/stackforge/cookbook-openstack-bare-metal/blob/master/recipes/api.rb#L52

Now next issue:
 Expected process to exit with [0], but received '1'
---- Begin output of /sbin/start ironic-conductor ----
STDOUT:
STDERR: start: Job is already running: ironic-conductor

The delayed restart of conductor is failing. Seems to be trying to start it when it's already started.

Ran, service ironic-conductor restart, manually and it worked fine. Not sure what's the issue here, I would think the Chef service provider would stop it first, then start it.

Mark Vanderwiel (vanderwl) wrote :

Ok, I think I found the issue, looks like a ubuntu bug, the /etc/init.d/ironic-conductor script is really just a dup of the ironic-api one, so it has all the wrong service names.
Opened ubuntu bug for this: https://bugs.launchpad.net/ubuntu/+source/ironic/+bug/1429962

Reviewed: https://review.openstack.org/162737
Committed: https://git.openstack.org/cgit/stackforge/openstack-chef-repo/commit/?id=aa48cfbb43b725088e66254d94773b9d8f4b0d0c
Submitter: Jenkins
Branch: master

commit aa48cfbb43b725088e66254d94773b9d8f4b0d0c
Author: Mark Vanderwiel <email address hidden>
Date: Mon Mar 9 13:59:28 2015 -0500

    Partial revert of putting bare-metal in repo roles

    Bug https://bugs.launchpad.net/ubuntu/+source/ironic/+bug/1429962
    in ubuntu repo will cause our repo tests to fail.
    To allow progress while this gets fixed, pulling bare-metal
    conductor from the os-compute-worker role.

    The other bare-metal patches for the cookbook should also get in to
    allow clean tests to be run.

    Change-Id: I936d90a93141402aac0639576da04fd4e2c8752e
    Related-Bug: #1429245

Reviewed: https://review.openstack.org/162003
Committed: https://git.openstack.org/cgit/stackforge/cookbook-openstack-bare-metal/commit/?id=70b47d394d9e89310e5ec7380b205ea1f251e456
Submitter: Jenkins
Branch: master

commit 70b47d394d9e89310e5ec7380b205ea1f251e456
Author: wenchma <email address hidden>
Date: Fri Mar 6 11:57:56 2015 +0800

    Add ironic common package for debain platform family

    Add irconic-common to the ubuntu common package list
    in default attributes.

    By the way, correct connection url that is messed up .

    Change-Id: I658670681d4a2f7f7ad5f584b9c1c24448da7384
    Closes-bug: #1428926
    Closes-bug: #1429245

Changed in openstack-chef:
status: In Progress → Fix Released
Ma Wen Cheng (mars914) wrote :

For comment#3 and comment#4, done, not reproduced the issue as comment#5

Ma Wen Cheng (mars914) wrote :

for the patch in comment#, I think we should not remove the conductor role in repo roles, conductor service fails to start, maybe it is not due to installation but configuration.

https://review.openstack.org/163439 this will fix some issues which are found.

Reviewed: https://review.openstack.org/163439
Committed: https://git.openstack.org/cgit/stackforge/cookbook-openstack-bare-metal/commit/?id=ded5cad8ee42ab487ac300dbdee2f84664103808
Submitter: Jenkins
Branch: master

commit ded5cad8ee42ab487ac300dbdee2f84664103808
Author: wenchma <email address hidden>
Date: Wed Mar 11 21:37:41 2015 +0800

    Fix some issues of ironic cookbook

    * Set default value for rpc_backend
    * Change from "create_schema" to "upgrade" when dbsync
    * Add some attributes
    * Add identity_uri configuration item
    * Add spec tests

    Change-Id: Ic57ff8ae9ce69c24211527ddacd23f94d1e417e9
    Closes-bug: #1429245

Reviewed: https://review.openstack.org/169444
Committed: https://git.openstack.org/cgit/stackforge/openstack-chef-repo/commit/?id=917de05735447a2a040533eb5e80e4335cf7e950
Submitter: Jenkins
Branch: master

commit 917de05735447a2a040533eb5e80e4335cf7e950
Author: Mark Vanderwiel <email address hidden>
Date: Tue Mar 31 13:04:23 2015 -0500

    Remove commented out ironic conductor

    The bugin ubuntu packaging has been fixed:
    https://bugs.launchpad.net/bugs/1429962

    Change-Id: I31686bd4195d34f920b718e07bcac2af94852ab1
    Related-Bug: #1429245

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers