[common] dependency specification syntax prevents upload to private supermarket

Bug #1425192 reported by Chris Crebolder on 2015-02-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack + Chef
High
Yi Ming Yin

Bug Description

Version 10.3.0 of cookbook-openstack-common breaks uploading to private supermarket instances by specifying an obsolete dependency syntax in metadata.rb:

$ knife supermarket share cookbook-openstack-common 'Other' -m privatesupermarket.mydomain.com
ERROR: Chef::Exceptions::ObsoleteDependencySyntax: The dependency specification syntax you are using is no longer valid. You may not specify more than one version constraint for a particular cookbook.
Consult http://wiki.opscode.com/display/chef/Metadata for the updated syntax.

Referring to:
depends 'apt', '>= 2.3.8', '< 3.0.0'
depends 'database', '>= 4.0.2', '< 5.0.0'
depends 'mysql', '>= 6.0.13', '< 7.0.0'
depends 'yum', '>= 3.5.2', '< 4.0.0'
depends 'yum-epel', '>= 0.6.0', '< 1.0.0'

in metadata.rb.

Mark Vanderwiel (vanderwl) wrote :

Humm, don't like that Chef seems to be back level when it comes to Berks version support. But I guess for now, we will have to fix this. I'm going to open an issue against Chef as I think it should be fixed to support this.

Changed in openstack-chef:
status: New → Confirmed
importance: Undecided → High
milestone: none → juno-stable

Fix proposed to branch: master
Review: https://review.openstack.org/158827

Changed in openstack-chef:
assignee: nobody → Mark Vanderwiel (vanderwl)
status: Confirmed → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/158869

Changed in openstack-chef:
assignee: Mark Vanderwiel (vanderwl) → Christopher M Luciano (cmlucian)

Change abandoned by Mark Vanderwiel (<email address hidden>) on branch: master
Review: https://review.openstack.org/158848
Reason: covered by https://review.openstack.org/#/c/158869/

Reviewed: https://review.openstack.org/158869
Committed: https://git.openstack.org/cgit/stackforge/cookbook-openstack-common/commit/?id=e8513184367346cd882195bd6437b7e047f5eda6
Submitter: Jenkins
Branch: master

commit e8513184367346cd882195bd6437b7e047f5eda6
Author: Christopher M Luciano <email address hidden>
Date: Tue Feb 24 15:29:32 2015 -0500

    Switch back to pessimistic version constraint

    Change-Id: Ie7038d8d971cedc0bc487c9b9373b444b66ed66d
    Partial-Bug: #1425192

Reviewed: https://review.openstack.org/158828
Committed: https://git.openstack.org/cgit/stackforge/cookbook-openstack-ops-database/commit/?id=820e502251b55e79250a782f0ba2afca99cfab6e
Submitter: Jenkins
Branch: master

commit 820e502251b55e79250a782f0ba2afca99cfab6e
Author: Mark Vanderwiel <email address hidden>
Date: Tue Feb 24 13:26:17 2015 -0600

    Switch back to pessimistic version constraint

    Change-Id: I30a27af5c80fbb01edaff0215e5aa56fd76f0aba
    Partial-Bug: #1425192

Reviewed: https://review.openstack.org/158827
Committed: https://git.openstack.org/cgit/stackforge/cookbook-openstack-ops-messaging/commit/?id=0b423a56d42444050877aa499cb2b302edb6e730
Submitter: Jenkins
Branch: master

commit 0b423a56d42444050877aa499cb2b302edb6e730
Author: Mark Vanderwiel <email address hidden>
Date: Tue Feb 24 13:22:52 2015 -0600

    Switch back to pessimistic version constraint

    Change-Id: I8b3e40cb39eb23931eecfbdd47f34640d3647924
    Partial-Bug: #1425192

Reviewed: https://review.openstack.org/158834
Committed: https://git.openstack.org/cgit/stackforge/cookbook-openstack-dashboard/commit/?id=782197b06a8014bed9dc6282ea7c30f6b931310d
Submitter: Jenkins
Branch: master

commit 782197b06a8014bed9dc6282ea7c30f6b931310d
Author: Mark Vanderwiel <email address hidden>
Date: Tue Feb 24 13:35:17 2015 -0600

    Switch back to pessimistic version constraint

    Change-Id: Ia2d463ada57a19fb4626339cc1d0806ab53cc318
    Partial-Bug: #1425192

Reviewed: https://review.openstack.org/158830
Committed: https://git.openstack.org/cgit/stackforge/cookbook-openstack-image/commit/?id=12977c0093273f5b601e660dbfc43e6cd733c41c
Submitter: Jenkins
Branch: master

commit 12977c0093273f5b601e660dbfc43e6cd733c41c
Author: Mark Vanderwiel <email address hidden>
Date: Tue Feb 24 13:31:19 2015 -0600

    Switch back to pessimistic version constraint

    Change-Id: I803e6d4aacc84e00c8724cd823aa57cc778da8e2
    Partial-Bug: #1425192

Reviewed: https://review.openstack.org/158841
Committed: https://git.openstack.org/cgit/stackforge/cookbook-openstack-compute/commit/?id=9f533734130ef40d4f3ba905cecb4a310ca5b3d4
Submitter: Jenkins
Branch: master

commit 9f533734130ef40d4f3ba905cecb4a310ca5b3d4
Author: Mark Vanderwiel <email address hidden>
Date: Tue Feb 24 13:54:38 2015 -0600

    Switch back to pessimistic version constraint

    Change-Id: Ib7111508747a0239e91dba0f1e07c7a5bfd0ff8e
    Partial-Bug: #1425192

Reviewed: https://review.openstack.org/158836
Committed: https://git.openstack.org/cgit/stackforge/cookbook-openstack-block-storage/commit/?id=8736b36606be2c7843ae44c6fbc0e793a2e8bce1
Submitter: Jenkins
Branch: master

commit 8736b36606be2c7843ae44c6fbc0e793a2e8bce1
Author: Mark Vanderwiel <email address hidden>
Date: Tue Feb 24 13:38:53 2015 -0600

    Switch back to pessimistic version constraint

    Change-Id: Ie50f2a0c2a5f8e7b09847511d2269d3ef1ae9633
    Partial-Bug: #1425192

Chris Crebolder (ccrebolder) wrote :

Thanks!

$ knife supermarket share openstack-common 'Other' -m https://privatesupermarket.mydomain.com
Generating metadata for openstack-common from /tmp/chef-openstack-common-build20150225-14554-1bg643j/openstack-common/metadata.rb
Making tarball openstack-common.tgz
Upload complete!

Still complained until I renamed the git repo to match the cookbook name but that is definitely a knife-supermarket issue. Only mentioning it in case someone else gets stuck on that.

Yi Ming Yin (yinym-m) wrote :

For change https://review.openstack.org/#/c/158836/2/metadata.rb, it has changed constraints on selinux and python cookbooks version. In previous version of block-storage cookbook, we always set the version constraints as >= (selinux >= 0.7.2 and python >= 1.4.6). But with this change, the version constraints have been narrowed (e.g. selinux to 0.7.x, 0.8.0 will not work anymore).

I think this should be a mistake, because the purpose of this bug is to remove the multiple constraints in one line. But those old valid constraints should not be changed.

Fix proposed to branch: master
Review: https://review.openstack.org/161991

Changed in openstack-chef:
assignee: Christopher M Luciano (cmlucian) → Yi Ming Yin (yinym-m)

Change abandoned by Yi Ming Yin (<email address hidden>) on branch: master
Review: https://review.openstack.org/161991
Reason: Version constraints need to be updated and ~> is a good way to limit the version in small and control range.

Changed in openstack-chef:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers