[compute] dhcp_domain should be set in nova.conf ?

Bug #1338664 reported by Nacer Laradji on 2014-07-07
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenStack + Chef
Medium
Unassigned
Icehouse
Undecided
Unassigned
Juno
Medium
Unassigned

Bug Description

Hi,

My network mode is Neutron.

It seem that stackforge cookbook don't set the dhcp_domain attribute in nova.conf when you use neutron for network.
https://github.com/stackforge/cookbook-openstack-compute/blob/master/templates/default/nova.conf.erb#L87

But if you don't set it to "" the metadaservice return something like this :

hostname+neutron/dhcp_agent.ini:dhcp_domain+nova/nova.conf:dhcp_domain

 Result -> vm01.example.net.novalocal

Changed in openstack-chef:
milestone: none → icehouse-stable

What is the issue or symptom for this issue?

how is this different from: /dhcp_agent.ini.erb:dhcp_domain = <%= node["openstack"]["network"]["dhcp"]["default_domain"] %>

Is there any neutron case to have this settable in nova.conf?

Nacer Laradji (nacer-laradji) wrote :

Hi,

The issue is that openstack default value for dhcp_domain exist and are hardcoded :

1 : neutron/dhcp_agent.ini:dhcp_domain == openstacklocal
2 : nova/nova.conf:dhcp_domain == novalocal

When you use neutron you set your domain in *1. But 2 have a default value to novalocal if not set to "".

tags: added: compute
JJ Asghar (d-jj) wrote :

Is this still an issue?

Nacer Laradji (nacer-laradji) wrote :

For havana, i think it is. For the other version of openstack cookbook i don't know.

JJ Asghar (d-jj) wrote :

havana is no longer supported. I'm going to close this and if this effects the other stable branches please reopen.

summary: - dhcp_domain should be set in nova.conf ?
+ [compute] dhcp_domain should be set in nova.conf ?
kraig (kamador) wrote :

Hey JJ, I can confirm this also effects Icehouse and I'd expect Juno as well.

JJ Asghar (d-jj) wrote :

We should investigate this farther. https://review.openstack.org/#/c/108367/

Changed in openstack-chef:
status: New → Triaged
milestone: none → kilo-rc1

Change abandoned by JJ Asghar (<email address hidden>) on branch: stable/havana
Review: https://review.openstack.org/108367
Reason: We don't support havana anymore.

no longer affects: openstack-chef/havana
Jan Klare (j-klare) on 2015-05-22
Changed in openstack-chef:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers