sitemap does not include translated API guides

Bug #1506601 reported by Andreas Jaeger on 2015-10-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openstack-api-site
Medium
Andreas Jaeger

Bug Description

I just regenerated the sitemap for developer.openstack.org and noticed that the translated API Guides (quick start) are not in the sitemap. Those are currently not in an index page on developer.openstack.org, they are only linked from docs.openstack.org

Anne Gentle (annegentle) on 2015-10-15
Changed in openstack-api-site:
status: New → Confirmed
Anne Gentle (annegentle) wrote :

Wondering if there's anything in the robots.txt file, but it's just this, so this looks okay to me:

# openstack-manuals/www/robots.txt
User-agent: Googlebot
Disallow: /*.pdf$

# Keep OpenStack users from accidentally using docs for the upcoming release
User-agent: *
Disallow: /draft/

We can certainly link from index.html, looks like it needs changing to the new RST-built one anyway.

Christian Berendt (berendt) wrote :

We cann add a list of start URLs to the spider that should be used as starting point. At the moment this is only developer.openstack.org. Andreas, can you please provide a list of additional URLs that should be used? I will have a look on the spider implementation we are using and document how to use additional start URLs.

Andreas Jaeger (jaegerandi) wrote :

http://docs.openstack.org/de/ links to the GErman API Guide, some for Japanese. Korean will follow.

URL:
http://developer.openstack.org/de/api-guide/quick-start/

Anne, we could also add "translated" index pages to developer.openstack.org like we do for docs.openstack.org.

summary: - sitemap not complete
+ sitemap does not include translated API guides
Anne Gentle (annegentle) wrote :

Ah, I hadn't realized there were some translations for API docs started. I think it's a good idea to add translated index pages to developer.openstack.org.

Changed in openstack-api-site:
importance: Undecided → Medium
Andreas Jaeger (jaegerandi) wrote :

This has been fixed now

Changed in openstack-api-site:
status: Confirmed → Fix Released
assignee: nobody → Andreas Jaeger (jaegerandi)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers