Quantum API - provider networks extension

Bug #1108118 reported by Salvatore Orlando
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openstack-api-site
Fix Released
High
Salvatore Orlando

Bug Description

The Provider networks extension, being a 'community supported' extension, should be documented in the main API reference.
There's also a stub for it.

Tags: netconn-api
Changed in openstack-api-site:
assignee: nobody → Salvatore Orlando (salvatore-orlando)
dan wendlandt (danwent)
Changed in openstack-api-site:
importance: Undecided → High
tags: added: netconn-api
Revision history for this message
Tom Fifield (fifieldt) wrote :

Hi,

Where can we find this one in the code?

Changed in openstack-api-site:
status: New → Incomplete
Revision history for this message
Salvatore Orlando (salvatore-orlando) wrote :

The extension is located in /extension/providernet.py

Unlike many extensions, this has no db class. Supported is implemented directly in plugins.
The main OSS plugins support it.

Tom Fifield (fifieldt)
Changed in openstack-api-site:
status: Incomplete → Confirmed
Revision history for this message
Salvatore Orlando (salvatore-orlando) wrote :
Changed in openstack-api-site:
status: Confirmed → In Progress
Tom Fifield (fifieldt)
Changed in openstack-api-site:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers