[WARNING]: It is unnecessary to use '{{' in loops, leave variables in loop expressions bare

Bug #1462572 reported by Shane Cunningham
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openstack-ansible
Juno
Fix Released
Low
Darren Birkett

Bug Description

This is just a warning message that is displayed when running the infra/openstack playbooks that 10.1.6 introduced. It doesn't break anything.

infrastructure-setup.yml

root@infra01:/opt/os-ansible-deployment/rpc_deployment# ansible-playbook -e @/etc/rpc_deploy/user_variables.yml playbooks/infrastructure/infrastructure-setup.yml
 [WARNING]: It is unnecessary to use '{{' in loops, leave variables in loop
expressions bare.

PLAY [memcached] **************************************************************

GATHERING FACTS ***************************************************************

openstack-setup.yml

root@infra01:/opt/os-ansible-deployment/rpc_deployment# ansible-playbook -e @/etc/rpc_deploy/user_variables.yml playbooks/openstack/openstack-setup.yml
 [WARNING]: It is unnecessary to use '{{' in loops, leave variables in loop
expressions bare.

PLAY [keystone] ***************************************************************

GATHERING FACTS ***************************************************************

Issue

root@infra01:/opt/os-ansible-deployment/rpc_deployment# grep -r "with_.*{{" .
./roles/container_common/tasks/container_user_create.yml: with_items: "{{ additional_system_groups }}"

Fix

with_items: additional_system_groups

https://github.com/stackforge/os-ansible-deployment/commit/4bc36f216ea7adef0ba10f045cf18ab5f3e80160#diff-d4916a8e4e9b67712fbd8ef6cac98099

Changed in openstack-ansible:
status: New → Triaged
importance: Undecided → Medium
milestone: none → 11.0.3
no longer affects: openstack-ansible/juno
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to os-ansible-deployment (juno)

Fix proposed to branch: juno
Review: https://review.openstack.org/191006

no longer affects: openstack-ansible/kilo
Changed in openstack-ansible:
milestone: 11.0.3 → none
no longer affects: openstack-ansible
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers