fix tox python3 overrides

Bug #1801657 reported by shupeng on 2018-11-05
This bug report is a duplicate of:  Bug #1801656: fix tox python3 overrides. Edit Remove
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openstack-ansible
Undecided
Unassigned

Bug Description

We want to default to running all tox environments under python 3, so
set the basepython value in each environment.

We do not want to specify a minor version number, because we do not
want to have to update the file every time we upgrade python.

We do not want to set the override once in testenv, because that
breaks the more specific versions used in default environments like
py35 and py36.

Reviewed: https://review.openstack.org/606761
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-rsyslog_client/commit/?id=cbe2113f5d3a75408a5c55345cf677b627b773f8
Submitter: Zuul
Branch: master

commit cbe2113f5d3a75408a5c55345cf677b627b773f8
Author: huang.zhiping <huang.zhiping@99cloud.net>
Date: Sun Sep 30 02:58:08 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: I8e1653369bc106b9d9438d6d5b111c90df74743d
    Closes-Bug: #1801657

Changed in openstack-ansible:
status: New → Fix Released

Reviewed: https://review.openstack.org/606769
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-plugins/commit/?id=2ebc891885bf87e0a7a33382db53a3a8bcc53e48
Submitter: Zuul
Branch: master

commit 2ebc891885bf87e0a7a33382db53a3a8bcc53e48
Author: huang.zhiping <huang.zhiping@99cloud.net>
Date: Sun Sep 30 03:13:56 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: I426af536281d4ea0c862c1415c89a365db9940b7
    Closes-Bug: #1801657

Reviewed: https://review.openstack.org/608571
Committed: https://git.openstack.org/cgit/openstack/ansible-hardening/commit/?id=543e885ffcce793b6208666bab17fae6f1a80076
Submitter: Zuul
Branch: master

commit 543e885ffcce793b6208666bab17fae6f1a80076
Author: 98k <18552437190@163.com>
Date: Mon Oct 8 05:17:20 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: If229d848b92ed10ea4b788598c575c5b9f693c90
    Closes-Bug: #1801657

Reviewed: https://review.openstack.org/606828
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-os_cinder/commit/?id=2e783371d77cfb1aeefcb3611e57d2f613c0d6d1
Submitter: Zuul
Branch: master

commit 2e783371d77cfb1aeefcb3611e57d2f613c0d6d1
Author: huang.zhiping <huang.zhiping@99cloud.net>
Date: Sun Sep 30 08:30:36 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: I6e8c0d17fb96e507547b61d1d8523b259d1fc204
    Closes-Bug: #1801657

Reviewed: https://review.openstack.org/606816
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-os_tempest/commit/?id=c77f4ded2a2e4e690202a593df45f543062ce39a
Submitter: Zuul
Branch: master

commit c77f4ded2a2e4e690202a593df45f543062ce39a
Author: huang.zhiping <huang.zhiping@99cloud.net>
Date: Sun Sep 30 08:12:32 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: I8fc994880c7ccbe7356e4c6470d28bb925f8c880
    Closes-Bug: #1801657

Reviewed: https://review.openstack.org/606821
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-os_swift/commit/?id=e965a6ddcb6686fee5efdbc2e6df3a206b88d4f4
Submitter: Zuul
Branch: master

commit e965a6ddcb6686fee5efdbc2e6df3a206b88d4f4
Author: huang.zhiping <huang.zhiping@99cloud.net>
Date: Sun Sep 30 08:20:18 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: I27b758fed3cdb4e65203d0b0051244fcde72b700
    Closes-Bug: #1801657

Reviewed: https://review.openstack.org/606792
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-nspawn_container_create/commit/?id=f60148b767eeed6ed8fe81d9f716a815c99333d7
Submitter: Zuul
Branch: master

commit f60148b767eeed6ed8fe81d9f716a815c99333d7
Author: huang.zhiping <huang.zhiping@99cloud.net>
Date: Sun Sep 30 07:37:51 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: I745314975cf50bc92bd0993f4a9738f37cbdf3ab
    Closes-Bug: #1801657

Reviewed: https://review.openstack.org/606808
Committed: https://git.openstack.org/cgit/openstack/ansible-role-systemd_service/commit/?id=bb9b88cbab9dfd27fcabdadf7b8377d2231da7ca
Submitter: Zuul
Branch: master

commit bb9b88cbab9dfd27fcabdadf7b8377d2231da7ca
Author: huang.zhiping <huang.zhiping@99cloud.net>
Date: Sun Sep 30 08:01:04 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: Iec4ce3ac5191130754f582178d1079f75bdffe8d
    Closes-Bug: #1801657

Reviewed: https://review.openstack.org/606763
Committed: https://git.openstack.org/cgit/openstack/ansible-role-systemd_networkd/commit/?id=759d4f0e7738d6056a1b756ca9d785c388bf7c94
Submitter: Zuul
Branch: master

commit 759d4f0e7738d6056a1b756ca9d785c388bf7c94
Author: huang.zhiping <huang.zhiping@99cloud.net>
Date: Sun Sep 30 03:01:36 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: I16451b1ff9446a87e411b67746b47929c3581d8d
    Closes-Bug: #1801657

Reviewed: https://review.openstack.org/606812
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-os_neutron/commit/?id=254615c41fb11a39d3af0a2c92a79e02a6265b0b
Submitter: Zuul
Branch: master

commit 254615c41fb11a39d3af0a2c92a79e02a6265b0b
Author: huang.zhiping <huang.zhiping@99cloud.net>
Date: Sun Sep 30 08:06:10 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: Ic0bbba6789598db4531df8a56091f17784c2628a
    Closes-Bug: #1801657

Reviewed: https://review.openstack.org/606759
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-rsyslog_server/commit/?id=289b30d46d5d2fa1dba1423a3c6aada527611690
Submitter: Zuul
Branch: master

commit 289b30d46d5d2fa1dba1423a3c6aada527611690
Author: huang.zhiping <huang.zhiping@99cloud.net>
Date: Sun Sep 30 02:48:33 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: I55900a348452ebdcfc8dd40bb40a5a5aaeece994
    Closes-Bug: #1801657

This issue was fixed in the openstack/tripleo-validations 10.2.0 release.

Reviewed: https://review.openstack.org/606825
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-os_barbican/commit/?id=7b58a52da00d080697ee666a45b19f3806c5109d
Submitter: Zuul
Branch: master

commit 7b58a52da00d080697ee666a45b19f3806c5109d
Author: huang.zhiping <huang.zhiping@99cloud.net>
Date: Sun Sep 30 08:25:46 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: Ibcfa628141ecdd8cd604cc1837bbaa2b7efcc8cb
    Closes-Bug: #1801657

This issue was fixed in the openstack/tripleo-common 10.4.0 release.

Reviewed: https://review.openstack.org/606802
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-ceph_client/commit/?id=0d2862cbfc22bc6278db27a49e2dcaa1bd514610
Submitter: Zuul
Branch: master

commit 0d2862cbfc22bc6278db27a49e2dcaa1bd514610
Author: huang.zhiping <huang.zhiping@99cloud.net>
Date: Sun Sep 30 07:51:28 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: Ia6bc30a733b61af8f30eb22f59bb499da76e54cb
    Closes-Bug: #1801657

Reviewed: https://review.openstack.org/606811
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-openstack_openrc/commit/?id=cbf739c20eda27e21ddaf43e9e5abd860de94198
Submitter: Zuul
Branch: master

commit cbf739c20eda27e21ddaf43e9e5abd860de94198
Author: huang.zhiping <huang.zhiping@99cloud.net>
Date: Sun Sep 30 08:04:23 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: If6d3815932ea2c128cec0fe93db49936de939963
    Closes-Bug: #1801657

Reviewed: https://review.openstack.org/606801
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-haproxy_server/commit/?id=0b372f91112b5f4c59319421a9897441c1e7f358
Submitter: Zuul
Branch: master

commit 0b372f91112b5f4c59319421a9897441c1e7f358
Author: huang.zhiping <huang.zhiping@99cloud.net>
Date: Sun Sep 30 07:49:53 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: I1d9a985c6c81f7ee789daa4c8529d33635503787
    Closes-Bug: #1801657

Reviewed: https://review.openstack.org/606767
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-pip_install/commit/?id=a605098e4886dad32934559a5381b9082b470f69
Submitter: Zuul
Branch: master

commit a605098e4886dad32934559a5381b9082b470f69
Author: huang.zhiping <huang.zhiping@99cloud.net>
Date: Sun Sep 30 03:09:32 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: I91a089d537319f03e9abbe790e35f5e314a42a57
    Closes-Bug: #1801657

Reviewed: https://review.openstack.org/606798
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-os_molteniron/commit/?id=cdfbf325ecc191068295b5c6b71698d4df936872
Submitter: Zuul
Branch: master

commit cdfbf325ecc191068295b5c6b71698d4df936872
Author: huang.zhiping <huang.zhiping@99cloud.net>
Date: Sun Sep 30 07:46:46 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: If2fa3b28e6a99dd5b80c20235cb87c4893cae3ed
    Closes-Bug: #1801657

Reviewed: https://review.openstack.org/606794
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-apt_package_pinning/commit/?id=62e4884853a1615648ab184adbf208e1be150baa
Submitter: Zuul
Branch: master

commit 62e4884853a1615648ab184adbf208e1be150baa
Author: huang.zhiping <huang.zhiping@99cloud.net>
Date: Sun Sep 30 07:41:46 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: I923a943291f7b0882b5ffe169a3d287747f0055e
    Closes-Bug: #1801657

Reviewed: https://review.openstack.org/615490
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-galera_server/commit/?id=8aa94263d27dd0b3ba8e20b897a4132de6cda4c5
Submitter: Zuul
Branch: master

commit 8aa94263d27dd0b3ba8e20b897a4132de6cda4c5
Author: huang.zhiping <huang.zhiping@99cloud.net>
Date: Mon Nov 5 07:43:24 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: I15b254299073e1c4437445f4f694643637b39558
    Closes-Bug: #1801657

Reviewed: https://review.openstack.org/606818
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-os_horizon/commit/?id=f793e0ed8ac551d215643aa4817da8a7692a1867
Submitter: Zuul
Branch: master

commit f793e0ed8ac551d215643aa4817da8a7692a1867
Author: huang.zhiping <huang.zhiping@99cloud.net>
Date: Sun Sep 30 08:15:18 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: I0a78b8a7a16b9f32a87a6a871cc4e0bc2d82e42e
    Closes-Bug: #1801657

Reviewed: https://review.openstack.org/606820
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-os_keystone/commit/?id=47deb80ba923a0f208e6a16aa0effb6bc1d2ba7c
Submitter: Zuul
Branch: master

commit 47deb80ba923a0f208e6a16aa0effb6bc1d2ba7c
Author: huang.zhiping <huang.zhiping@99cloud.net>
Date: Sun Sep 30 08:18:24 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: I36b010f4b0db7b2dbe934d4ab5752ea7c0be2d54
    Closes-Bug: #1801657

Reviewed: https://review.openstack.org/606757
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-os_masakari/commit/?id=af4287f9ae74b04e78b68fb79f28570a968a7add
Submitter: Zuul
Branch: master

commit af4287f9ae74b04e78b68fb79f28570a968a7add
Author: huang.zhiping <huang.zhiping@99cloud.net>
Date: Sun Sep 30 02:46:09 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: Iabd666d8a9143f197893d0f7fea786adc8a9055f
    Closes-Bug: #1801657

Reviewed: https://review.openstack.org/609973
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-memcached_server/commit/?id=5895ad56370ce00f226d36679afeb1da9ea997ce
Submitter: Zuul
Branch: master

commit 5895ad56370ce00f226d36679afeb1da9ea997ce
Author: Vieri <15050873171@163.com>
Date: Fri Oct 12 09:03:31 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: I76d4aeeb50299a43164dc32fe1f91b47ec194bb1
    Closes-Bug: #1801657

Reviewed: https://review.openstack.org/609980
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-openstack_hosts/commit/?id=b30a28b64dd247b700c02dba2f00a67e6b04b769
Submitter: Zuul
Branch: master

commit b30a28b64dd247b700c02dba2f00a67e6b04b769
Author: Vieri <15050873171@163.com>
Date: Fri Oct 12 09:17:53 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: I3dc33f7dbbbf691255ead0ccb1acaeb3e1ddb6c9
    Closes-Bug: #1801657

Reviewed: https://review.openstack.org/609977
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-os_almanach/commit/?id=f475bb53bbea7c8d12767e100b3f7922fbb22ad7
Submitter: Zuul
Branch: master

commit f475bb53bbea7c8d12767e100b3f7922fbb22ad7
Author: Vieri <15050873171@163.com>
Date: Fri Oct 12 09:12:56 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: Ib41b2ea8657a996459e43caaac81f5020c0bb31a
    Closes-Bug: #1801657

Reviewed: https://review.openstack.org/609975
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-os_gnocchi/commit/?id=3f8c2ee32465ad030d0ffa9f6125cf432c09adea
Submitter: Zuul
Branch: master

commit 3f8c2ee32465ad030d0ffa9f6125cf432c09adea
Author: Vieri <15050873171@163.com>
Date: Fri Oct 12 09:06:29 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: I7a526b86f10a871630a6362827d4dcb80ea58342
    Closes-Bug: #1801657

Reviewed: https://review.openstack.org/609976
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-os_heat/commit/?id=7037916858d22bf9dd0165e3b70be60ec9567eb5
Submitter: Zuul
Branch: master

commit 7037916858d22bf9dd0165e3b70be60ec9567eb5
Author: Vieri <15050873171@163.com>
Date: Fri Oct 12 09:10:31 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: Id666842a71e7b5ba3165e9ad5aac11ed4480e2e6
    Closes-Bug: #1801657

Reviewed: https://review.openstack.org/609979
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-os_ceilometer/commit/?id=d2e5ce53d221ab7626ceb589a82dbb5079dd0840
Submitter: Zuul
Branch: master

commit d2e5ce53d221ab7626ceb589a82dbb5079dd0840
Author: Vieri <15050873171@163.com>
Date: Fri Oct 12 09:14:36 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: I62890be07192cd9baad6da87a13142c494bf4fa9
    Closes-Bug: #1801657

Reviewed: https://review.openstack.org/606756
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-os_glance/commit/?id=7db1a56ff5f5e1b0cfb0be409373af9713fa96c2
Submitter: Zuul
Branch: master

commit 7db1a56ff5f5e1b0cfb0be409373af9713fa96c2
Author: huang.zhiping <huang.zhiping@99cloud.net>
Date: Sun Sep 30 02:42:11 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: I8cceae74275c7d6a5dda17d42614dc6478f10299
    Closes-Bug: #1801657

Reviewed: https://review.openstack.org/606785
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-os_tacker/commit/?id=b7c4039f13874fce05f218b41701b95752aefb4d
Submitter: Zuul
Branch: master

commit b7c4039f13874fce05f218b41701b95752aefb4d
Author: huang.zhiping <huang.zhiping@99cloud.net>
Date: Sun Sep 30 07:01:10 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: I02275ae673bf6f1664b22012d076db4011634553
    Closes-Bug: #1801657

This issue was fixed in the openstack/magnum-tempest-plugin 0.2.0 release.

Reviewed: https://review.openstack.org/606786
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-os_rally/commit/?id=707c8dbedb1e410f0401730505254730f50b7043
Submitter: Zuul
Branch: master

commit 707c8dbedb1e410f0401730505254730f50b7043
Author: huang.zhiping <huang.zhiping@99cloud.net>
Date: Sun Sep 30 07:02:39 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: I61b7509084240a2828afea5ed1ee477907cf4c79
    Closes-Bug: #1801657

Reviewed: https://review.openstack.org/606796
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-os_zun/commit/?id=5576155a8bb173d214b1989ba3ec43f8e2285ee2
Submitter: Zuul
Branch: master

commit 5576155a8bb173d214b1989ba3ec43f8e2285ee2
Author: huang.zhiping <huang.zhiping@99cloud.net>
Date: Sun Sep 30 07:45:30 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: Ib12c795adf06d34e02eb2942f65c0789a3b6621b
    Closes-Bug: #1801657

Reviewed: https://review.openstack.org/606778
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-lxc_container_create/commit/?id=dd322588586e1ad88b91d69b5067d1b3963a4c8b
Submitter: Zuul
Branch: master

commit dd322588586e1ad88b91d69b5067d1b3963a4c8b
Author: huang.zhiping <huang.zhiping@99cloud.net>
Date: Sun Sep 30 06:27:22 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: I0948580a0a76a70d8276ead61de95c1965a1d324
    Closes-Bug: #1801657

Reviewed: https://review.openstack.org/606822
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-os_designate/commit/?id=0295e9fa556beb04e913e41a6047190f93cc51c4
Submitter: Zuul
Branch: master

commit 0295e9fa556beb04e913e41a6047190f93cc51c4
Author: huang.zhiping <huang.zhiping@99cloud.net>
Date: Sun Sep 30 08:21:30 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: Idf52b7aeecc46b3ff14cf9e2b3a7c4401987c574
    Closes-Bug: #1801657

Reviewed: https://review.openstack.org/606804
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-os_monasca/commit/?id=1b94921f1b8f6e3a003b23fcc7974d10105ae04d
Submitter: Zuul
Branch: master

commit 1b94921f1b8f6e3a003b23fcc7974d10105ae04d
Author: huang.zhiping <huang.zhiping@99cloud.net>
Date: Sun Sep 30 07:52:57 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: Ib8da36984dfe9d437f591c7f01e007496836cab2
    Closes-Bug: #1801657

Reviewed: https://review.openstack.org/606813
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-ops/commit/?id=da254f1845e346da5957d15f567ef86d79efda0f
Submitter: Zuul
Branch: master

commit da254f1845e346da5957d15f567ef86d79efda0f
Author: huang.zhiping <huang.zhiping@99cloud.net>
Date: Sun Sep 30 08:07:16 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: I66c21e3cf648dc5fcb83a9302d235c546d502305
    Closes-Bug: #1801657

This issue was fixed in the openstack/tripleo-heat-templates 10.5.0 release.

Reviewed: https://review.opendev.org/606787
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-os_trove/commit/?id=e0314d133906604e64662260098dcf6669b7d8c7
Submitter: Zuul
Branch: master

commit e0314d133906604e64662260098dcf6669b7d8c7
Author: huang.zhiping <huang.zhiping@99cloud.net>
Date: Sun Sep 30 07:04:12 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: Ibddd61b7a9e9b78905d548b5ab00e64277449114
    Closes-Bug: #1801657

Reviewed: https://review.opendev.org/606793
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-os_sahara/commit/?id=f18a851d982223dfdf74ec5c539191395c94ab37
Submitter: Zuul
Branch: master

commit f18a851d982223dfdf74ec5c539191395c94ab37
Author: huang.zhiping <huang.zhiping@99cloud.net>
Date: Sun Sep 30 07:40:12 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: I88f8c1c8730d4d8f5100e69e6a670f6ee02a158d
    Closes-Bug: #1801657

Reviewed: https://review.opendev.org/607450
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-nspawn_hosts/commit/?id=86f60b6a200d4393d11df511fb9e1cf67a06a3f1
Submitter: Zuul
Branch: master

commit 86f60b6a200d4393d11df511fb9e1cf67a06a3f1
Author: huang.zhiping <huang.zhiping@99cloud.net>
Date: Wed Oct 3 02:17:32 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: If5ec0826d9f6b664f71f457b55f1674f8e0848e1
    Closes-Bug: #1801657

Reviewed: https://review.opendev.org/606780
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-repo_build/commit/?id=ff7c76e3e5a9dffb6df2dfcbe0e58b10a8725746
Submitter: Zuul
Branch: master

commit ff7c76e3e5a9dffb6df2dfcbe0e58b10a8725746
Author: huang.zhiping <huang.zhiping@99cloud.net>
Date: Sun Sep 30 06:32:05 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: I67f6301eb296fae9fedfea189ceeef42c59280d8
    Closes-Bug: #1801657

Reviewed: https://review.opendev.org/606824
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-os_aodh/commit/?id=ea262b41bcb22af27809642fc1083ded2704cfb5
Submitter: Zuul
Branch: master

commit ea262b41bcb22af27809642fc1083ded2704cfb5
Author: huang.zhiping <huang.zhiping@99cloud.net>
Date: Sun Sep 30 08:24:32 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: I92dcc6339f6877f3edffe1c2ce919c5a38b47fa5
    Closes-Bug: #1801657

Reviewed: https://review.opendev.org/606806
Committed: https://git.openstack.org/cgit/openstack/ansible-role-python_venv_build/commit/?id=7c91d603dd6f24c282ca13809ee87abfbc6ca9e6
Submitter: Zuul
Branch: master

commit 7c91d603dd6f24c282ca13809ee87abfbc6ca9e6
Author: huang.zhiping <huang.zhiping@99cloud.net>
Date: Sun Sep 30 07:55:26 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: I14400678a53a66e2b0d1a5377d881b9df7dbfc71
    Closes-Bug: #1801657

Reviewed: https://review.opendev.org/606783
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-os_panko/commit/?id=3af0ec4fa8b6a6a8f8acb2a383302bbb806c63d2
Submitter: Zuul
Branch: master

commit 3af0ec4fa8b6a6a8f8acb2a383302bbb806c63d2
Author: huang.zhiping <huang.zhiping@99cloud.net>
Date: Sun Sep 30 06:58:32 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: I6859353c8b79b1e111ec2e13ab8f265e008715b7
    Closes-Bug: #1801657

Reviewed: https://review.opendev.org/606823
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-os_magnum/commit/?id=d25513f3a835db41945d5f2e4778e0159e517d5a
Submitter: Zuul
Branch: master

commit d25513f3a835db41945d5f2e4778e0159e517d5a
Author: huang.zhiping <huang.zhiping@99cloud.net>
Date: Sun Sep 30 08:23:07 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: I81b29590187111cfa9770e4105883c943272a7d1
    Closes-Bug: #1801657

Reviewed: https://review.opendev.org/606814
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-os_congress/commit/?id=363e2656fcb56bc844f2f1d7ea3f0ac6861870ce
Submitter: Zuul
Branch: master

commit 363e2656fcb56bc844f2f1d7ea3f0ac6861870ce
Author: huang.zhiping <huang.zhiping@99cloud.net>
Date: Sun Sep 30 08:09:39 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: I535d4a092890b1198e625fa2d5d83635d3ff9731
    Closes-Bug: #1801657

Reviewed: https://review.opendev.org/606764
Committed: https://git.openstack.org/cgit/openstack/ansible-role-systemd_mount/commit/?id=5ce4554e1f9ee4b001965301a0f6a74b8f7dfbef
Submitter: Zuul
Branch: master

commit 5ce4554e1f9ee4b001965301a0f6a74b8f7dfbef
Author: huang.zhiping <huang.zhiping@99cloud.net>
Date: Sun Sep 30 03:02:59 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: I753c3a1167bb8ddae3e9a41b9e4dd8d93d4091ce
    Closes-Bug: #1801657

Change abandoned by Mohammed Naser (<email address hidden>) on branch: master
Review: https://review.opendev.org/606781
Reason: role retired

Change abandoned by Mohammed Naser (<email address hidden>) on branch: master
Review: https://review.opendev.org/606782
Reason: role retired

Reviewed: https://review.opendev.org/606777
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-rabbitmq_server/commit/?id=35aa8e534a74986891eb5eab8e0138c6cd726724
Submitter: Zuul
Branch: master

commit 35aa8e534a74986891eb5eab8e0138c6cd726724
Author: huang.zhiping <huang.zhiping@99cloud.net>
Date: Sun Sep 30 06:25:09 2018 +0000

    fix tox python3 overrides

    We want to default to running all tox environments under python 3, so
    set the basepython value in each environment.

    We do not want to specify a minor version number, because we do not
    want to have to update the file every time we upgrade python.

    We do not want to set the override once in testenv, because that
    breaks the more specific versions used in default environments like
    py35 and py36.

    Change-Id: I7704b6d9620eb3bd4c98a57f82268422fcb1852a
    Closes-Bug: #1801657

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers