openstack-ansible-galera_server role needlessly removes and reinstalls MariaDB-server

Bug #1762421 reported by Vadim Kuznetsov on 2018-04-09
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
openstack-ansible
High
Vadim Kuznetsov

Bug Description

This is the result of bug 1742206 fix.
openstack-ansible version is 17.0.1
Appling galera-install.yml playbook to healthy galera cluster will fail, as MariaDB-servers is removed, service stopped, and it's not started again.

description: updated

CentOS I guess?

Vadim Kuznetsov (vakuznet) wrote :

Yes, centos.

Changed in openstack-ansible:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Jean-Philippe Evrard (jean-philippe-evrard)

Fix proposed to branch: master
Review: https://review.openstack.org/578844

Changed in openstack-ansible:
assignee: Jean-Philippe Evrard (jean-philippe-evrard) → Vadim Kuznetsov (vakuznet)
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/578844
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-galera_server/commit/?id=270eccd82aedf240e5bcc52876b226808f104bba
Submitter: Zuul
Branch: master

commit 270eccd82aedf240e5bcc52876b226808f104bba
Author: Vadim Kuznetsov <email address hidden>
Date: Thu Jun 28 11:18:49 2018 -0400

    Do not remove MariaDB-server

    Removing mariadb-server and mariadb-libs leads to
    removing MariaDB-server and MariaDB-shared and its
    dependencies
    rpmquery --whatprovides mariadb-server
    MariaDB-server-10.1.30-1.el7.centos.x86_64
    rpmquery --whatprovides mariadb-libs
    MariaDB-shared-10.1.30-1.el7.centos.x86_64

    Which in turn shuts down the server.

    Change-Id: I89df8f6b57b1ebe0ce96d63f193da35107d2bad9
    Closes-Bug: #1762421
    Related-Bug: #1742206

Changed in openstack-ansible:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/589973
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-galera_server/commit/?id=2ca18bb2761f9fe99ea5eb29cba8e345966daf05
Submitter: Zuul
Branch: stable/queens

commit 2ca18bb2761f9fe99ea5eb29cba8e345966daf05
Author: Vadim Kuznetsov <email address hidden>
Date: Thu Jun 28 11:18:49 2018 -0400

    Do not remove MariaDB-server

    Removing mariadb-server and mariadb-libs leads to
    removing MariaDB-server and MariaDB-shared and its
    dependencies
    rpmquery --whatprovides mariadb-server
    MariaDB-server-10.1.30-1.el7.centos.x86_64
    rpmquery --whatprovides mariadb-libs
    MariaDB-shared-10.1.30-1.el7.centos.x86_64

    Which in turn shuts down the server.

    Change-Id: I89df8f6b57b1ebe0ce96d63f193da35107d2bad9
    Closes-Bug: #1762421
    Related-Bug: #1742206
    (cherry picked from commit 270eccd82aedf240e5bcc52876b226808f104bba)

tags: added: in-stable-queens

Reviewed: https://review.openstack.org/603215
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-galera_server/commit/?id=72f402d3e969c94754ade02953d2c94ce541b25e
Submitter: Zuul
Branch: master

commit 72f402d3e969c94754ade02953d2c94ce541b25e
Author: Jesse Pretorius <email address hidden>
Date: Mon Sep 17 20:25:02 2018 +0100

    Revisit conflicting package removal

    In https://review.openstack.org/534819 we introduced the removal
    of conflicting packages from the targeted host, but then we deleted
    the list for RedHat in https://review.openstack.org/578844 because
    yum kept removing and re-adding the same packages.

    In https://review.openstack.org/603205 we solve the issue properly
    given that yum is case-insensitive, and the root cause of the repeat
    remove/install.

    As such, in this patch, we restore the removal of conflicting
    packages for RedHat in a different way. Each of the package removal
    tasks are moved into the tasks specific to each package manager so
    that each can be handled differently.

    Change-Id: I70fbfa6eff8796713c6bec32319382273f8281f8
    Related-Bug: #1762421
    Related-Bug: #1742206

Reviewed: https://review.openstack.org/603388
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-galera_server/commit/?id=aff86072af40e4895a3f87a1f99aa66cb54a9290
Submitter: Zuul
Branch: stable/queens

commit aff86072af40e4895a3f87a1f99aa66cb54a9290
Author: Jesse Pretorius <email address hidden>
Date: Mon Sep 17 20:25:02 2018 +0100

    Revisit conflicting package removal

    In https://review.openstack.org/534819 we introduced the removal
    of conflicting packages from the targeted host, but then we deleted
    the list for RedHat in https://review.openstack.org/578844 because
    yum kept removing and re-adding the same packages.

    In https://review.openstack.org/603205 we solve the issue properly
    given that yum is case-insensitive, and the root cause of the repeat
    remove/install.

    As such, in this patch, we restore the removal of conflicting
    packages for RedHat in a different way. Each of the package removal
    tasks are moved into the tasks specific to each package manager so
    that each can be handled differently.

    Change-Id: I70fbfa6eff8796713c6bec32319382273f8281f8
    Related-Bug: #1762421
    Related-Bug: #1742206
    (cherry picked from commit 72f402d3e969c94754ade02953d2c94ce541b25e)

tags: added: in-stable-rocky

Reviewed: https://review.openstack.org/603383
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-galera_server/commit/?id=943b0360a7c85e157d0c24abe47215462395ae16
Submitter: Zuul
Branch: stable/rocky

commit 943b0360a7c85e157d0c24abe47215462395ae16
Author: Jesse Pretorius <email address hidden>
Date: Mon Sep 17 20:25:02 2018 +0100

    Revisit conflicting package removal

    In https://review.openstack.org/534819 we introduced the removal
    of conflicting packages from the targeted host, but then we deleted
    the list for RedHat in https://review.openstack.org/578844 because
    yum kept removing and re-adding the same packages.

    In https://review.openstack.org/603205 we solve the issue properly
    given that yum is case-insensitive, and the root cause of the repeat
    remove/install.

    As such, in this patch, we restore the removal of conflicting
    packages for RedHat in a different way. Each of the package removal
    tasks are moved into the tasks specific to each package manager so
    that each can be handled differently.

    Change-Id: I70fbfa6eff8796713c6bec32319382273f8281f8
    Related-Bug: #1762421
    Related-Bug: #1742206
    (cherry picked from commit 72f402d3e969c94754ade02953d2c94ce541b25e)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers