Prepare the deployment host in OpenStack-Ansible

Bug #1759721 reported by Father Vlasie on 2018-03-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openstack-ansible
Medium
Jesse Pretorius

Bug Description

This bug tracker is for errors with the documentation, use the following as a template and remove or add fields as you see fit. Convert [ ] into [x] to check boxes:

- [x ] This doc is inaccurate in this way: the CentOS repo references Pike but this is the Queens install guide.

- [ ] This is a doc addition request.
- [ ] I have a fix to the document that I can paste below including example: input and output.

If you have a troubleshooting or support issue, use the following resources:

 - Ask OpenStack: http://ask.openstack.org
 - The mailing list: http://lists.openstack.org
 - IRC: 'openstack' channel on Freenode

-----------------------------------
Release: 17.0.1.dev52 on 2018-03-27 14:54
SHA: 85714acedb50ea65d7e7684c127984c8dc56afe4
Source: https://git.openstack.org/cgit/openstack/openstack-ansible/tree/deploy-guide/source/deploymenthost.rst
URL: https://docs.openstack.org/project-deploy-guide/openstack-ansible/queens/deploymenthost.html

Changed in openstack-ansible:
status: New → Confirmed
importance: Undecided → Medium
tags: added: low-hanging-fruit

Fix proposed to branch: master
Review: https://review.openstack.org/558558

Changed in openstack-ansible:
assignee: nobody → Jesse Pretorius (jesse-pretorius)
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/558558
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible/commit/?id=ca49f4121e00fc637b5ac174e4012be6c2a67632
Submitter: Zuul
Branch: master

commit ca49f4121e00fc637b5ac174e4012be6c2a67632
Author: Jesse Pretorius <email address hidden>
Date: Tue Apr 3 17:48:13 2018 +0100

    Ensure that RDO/SUSE series repo instructions stay up to date

    The deployment host documentation gets out of date really quickly.
    This patch makes it self maintaining. Note that due to the fact
    that RDO/SUSE do not implement their repositories for a new
    release until much, much later in the cycle, we use the previous
    release repo for master. This will self-update during our RC
    when the stable branch is cut.

    Some formatting adjustments have made to prevent the interpretation
    of URL's as links by sphinx and to remove the use of multi-line shell
    commands.

    Closes-Bug: #1759721
    Change-Id: Id28540d335390a52e0eb65a734a1d594235265d6

Changed in openstack-ansible:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/558777
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible/commit/?id=611ba5b20c26b0796fb60f033fb7f696d80b171e
Submitter: Zuul
Branch: stable/queens

commit 611ba5b20c26b0796fb60f033fb7f696d80b171e
Author: Jesse Pretorius <email address hidden>
Date: Wed Apr 4 11:33:48 2018 +0100

    Ensure that RDO/SUSE series repo instructions stay up to date

    The deployment host documentation gets out of date really quickly.
    This patch makes it self maintaining.

    Note that due to the fact that this is a stable branch and that
    the documentation configuration is vastly different to master,
    this is a re-implementation rather than a backport.

    Some formatting adjustments have made to prevent the interpretation
    of URL's as links by sphinx and to remove the use of multi-line shell
    commands.

    Closes-Bug: #1759721
    Change-Id: Id28540d335390a52e0eb65a734a1d594235265d6

tags: added: in-stable-queens

Reviewed: https://review.openstack.org/558778
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible/commit/?id=c3c997895b985b6ffa5decd1a68264f8752d2b07
Submitter: Zuul
Branch: stable/pike

commit c3c997895b985b6ffa5decd1a68264f8752d2b07
Author: Jesse Pretorius <email address hidden>
Date: Wed Apr 4 11:33:48 2018 +0100

    Ensure that RDO/SUSE series repo instructions stay up to date

    The deployment host documentation gets out of date really quickly.
    This patch makes it self maintaining.

    Note that due to the fact that this is a stable branch and that
    the documentation configuration is vastly different to master,
    this is a re-implementation rather than a backport.

    Some formatting adjustments have made to prevent the interpretation
    of URL's as links by sphinx and to remove the use of multi-line shell
    commands.

    Closes-Bug: #1759721
    Change-Id: Id28540d335390a52e0eb65a734a1d594235265d6

tags: added: in-stable-pike

This issue was fixed in the openstack/openstack-ansible 16.0.10 release.

This issue was fixed in the openstack/openstack-ansible 17.0.2 release.

This issue was fixed in the openstack/openstack-ansible 18.0.0.0b1 development milestone.

This issue was fixed in the openstack/openstack-ansible 18.0.0.0b2 development milestone.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers