no configuration for osa neutron to configure external dns yet

Bug #1687594 reported by Jirayut Nimsaeng on 2017-05-02
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
openstack-ansible
Wishlist
Albert Mikaelyan

Bug Description

I'm trying to test OpenStack Designate playbook and found that Neutron need to be configured according to https://docs.openstack.org/ocata/networking-guide/config-dns-int.html#configuring-openstack-networking-for-integration-with-an-external-dns-service So this need to be done for fully working Designate.

For now the workaround would be to use the neutron.conf config override to enable this. It'd be ideal to have this automatically wired though.

tags: added: low-hanging-fruit
Changed in openstack-ansible:
status: New → Confirmed
importance: Undecided → Wishlist
bhujay kumar (bhatta) wrote :

I tried to use this override as per the documented example. added designate section in neutron.conf but it is not working . neutron retruns an error neutron.db.dns_db DNSDomainNotFound: Domain itc.in. not found in the external DNS service. I suspect I am going wrong somewhere in the designate section under neutron.conf. the detail description is here https://ask.openstack.org/en/question/107367/dnsdomainnotfound-while-integrating-neutron-with-designate/

Any help is highly appreciated .

Filippo DiNoto (fdinoto) wrote :

It looks like the config override worked correctly in terms of modifying your neutron.conf. The ongoing difficulties don't seem to be related to the bug. I commented on your ask.openstack.org question.

Changed in openstack-ansible:
assignee: nobody → Filippo DiNoto (fdinoto)

Fix proposed to branch: master
Review: https://review.openstack.org/504759

Changed in openstack-ansible:
status: Confirmed → In Progress
Albert Mikaelyan (tahvok) wrote :

I've just tried this and it appears that os-neutron-install.yml would fail as designate variables would not exist in it's play.
You should add designate variables to group_vars/all.yml with this change.

See log:
TASK [os_neutron : Copy common neutron config] *********************************
Tuesday 26 September 2017 13:24:48 +0000 (0:00:00.651) 0:00:49.866 *****
fatal: [controller1_neutron_server_container-191d95b7]: FAILED! => {"failed": true, "msg": "'designate_service_url' is undefined"}
fatal: [controller2_neutron_server_container-a0b2414b]: FAILED! => {"failed": true, "msg": "'designate_service_url' is undefined"}

Changed in openstack-ansible:
assignee: Filippo DiNoto (fdinoto) → Albert Mikaelyan (tahvok)
Albert Mikaelyan (tahvok) wrote :

I've opened a bug in Neutron:
https://bugs.launchpad.net/neutron/+bug/1725630

However, as it is still not fixed, should I supply the working configuration patch, or wait until neutron fixes the problem?

Reviewed: https://review.openstack.org/510654
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible-os_neutron/commit/?id=54d75036f4e29025a9af17767fa6723f9a9a1f68
Submitter: Zuul
Branch: master

commit 54d75036f4e29025a9af17767fa6723f9a9a1f68
Author: Albert Mikaelyan <email address hidden>
Date: Mon Oct 9 21:35:37 2017 +0300

    Add [designate] section in neutron.conf

    If neutron_designate_enabled variable is true,
    this will enable the [designate] section and all needed configuration.

    Change-Id: I82469a1de6a7ebce8ca2f568c1bb8125bbc57965
    Closes-Bug: 1687594

Changed in openstack-ansible:
status: In Progress → Fix Released
Albert Mikaelyan (tahvok) wrote :

Reopening as https://review.openstack.org/#/c/510650/ should also be merged

Changed in openstack-ansible:
status: Fix Released → In Progress
Changed in openstack-ansible:
assignee: Albert Mikaelyan (tahvok) → Jesse Pretorius (jesse-pretorius)
Changed in openstack-ansible:
assignee: Jesse Pretorius (jesse-pretorius) → Albert Mikaelyan (tahvok)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers