Issue with keepalived 1.2.7 when running multiple backup hosts with the same priority

Bug #1545066 reported by Jean-Philippe Evrard on 2016-02-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openstack-ansible
Medium
Jean-Philippe Evrard
Liberty
Medium
Jean-Philippe Evrard
Trunk
Medium
Jean-Philippe Evrard

Bug Description

When HAProxy is configured on multiple hosts, keepalived is used by default.
If running on 2 hosts, the issue won't appear.

When running on 3 hosts or more, with the current configuration, 2 of them will be considered as slaves, and will have the same priority.

This poses a problem with keepalived 1.2.7 and is fixed in the next version of keepalived.

Changed in openstack-ansible:
assignee: nobody → Jean-Philippe Evrard (jean-philippe-evrard)

Fix proposed to branch: master
Review: https://review.openstack.org/279730

Changed in openstack-ansible:
status: New → In Progress

Reviewed: https://review.openstack.org/279664
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible/commit/?id=03cfb7e9fd12694243bac9696328591f4e5428c1
Submitter: Jenkins
Branch: liberty

commit 03cfb7e9fd12694243bac9696328591f4e5428c1
Author: Jean-Philippe Evrard <email address hidden>
Date: Fri Feb 12 17:46:35 2016 +0100

    Information about the keepalived bug when multiple backup nodes
    have the same priority.

    This text is only relevant if the latest version of the
    keepalived role doesn't get backported to liberty.

    Bug: #1545066
    Change-Id: Ib4634b8de84b614c33df60255ddf1134c023cf05

tags: added: in-liberty

Reviewed: https://review.openstack.org/279730
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible/commit/?id=12a3fbafd03ff7272125a7b71e4538dadd252699
Submitter: Jenkins
Branch: master

commit 12a3fbafd03ff7272125a7b71e4538dadd252699
Author: Jean-Philippe Evrard <email address hidden>
Date: Fri Feb 12 20:09:24 2016 +0100

    Fixing keepalived bug when 2+ backup nodes have the same priority

    The issue is present if you're running 2 or more nodes with
    a keepalived < 1.2.8. This bumps the version of keepalived role
    (installing a more recent version of keepalived by default) AND
    edits the keepalived configuration file to avoid having nodes
    with the same priority.

    This will restart your keepalived service.

    Please note this commit is not meant for backporting. The deployer
    running on mitaka and below should follow the documentation here:
    https://review.openstack.org/#/c/279664/

    Bug: #1545066

    Change-Id: Ie28d2d3fa8670212c64ecbdf5a87314e7ca0a2d9

Changed in openstack-ansible:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/305913
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible/commit/?id=3468bf256576edc4acd364dbbe922ce92a579755
Submitter: Jenkins
Branch: stable/mitaka

commit 3468bf256576edc4acd364dbbe922ce92a579755
Author: Jean-Philippe Evrard <email address hidden>
Date: Fri Feb 12 20:09:24 2016 +0100

    Fixing keepalived bug when 2+ backup nodes have the same priority

    The issue is present if you're running 2 or more nodes with
    a keepalived < 1.2.8. This bumps the version of keepalived role
    (installing a more recent version of keepalived by default) AND
    edits the keepalived configuration file to avoid having nodes
    with the same priority.

    This will restart your keepalived service.

    Please note this commit is not meant for backporting. The deployer
    running on mitaka and below should follow the documentation here:
    https://review.openstack.org/#/c/279664/

    Bug: #1545066

    Change-Id: Ie28d2d3fa8670212c64ecbdf5a87314e7ca0a2d9
    (cherry picked from commit 12a3fbafd03ff7272125a7b71e4538dadd252699)

tags: added: in-stable-mitaka
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers