server_id missing in my.cnf

Bug #1479484 reported by Paul Halmos
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openstack-ansible
Fix Released
Medium
Darren Birkett
Juno
Won't Fix
Medium
Unassigned
Kilo
Fix Released
Medium
Tom Cameron
Trunk
Fix Released
Medium
Darren Birkett

Bug Description

Server_id needs to be set in my.cnf to each infra nodes unique ID.

server_id = N (i.e. server_id = 3 on infr003, server_id=2 on infra002, etc.)

Revision history for this message
Paul Halmos (paul-halmos) wrote :

This is needed as described in this MySQL documentation:

https://dev.mysql.com/doc/refman/5.0/en/replication-howto-existingdata.html

This needs to be set under [mysqld] in my.cnf as described here:

https://dev.mysql.com/doc/refman/5.0/en/replication-howto-slavebaseconfig.html

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to os-ansible-deployment (master)

Fix proposed to branch: master
Review: https://review.openstack.org/209404

Changed in openstack-ansible:
status: Confirmed → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to openstack-ansible (master)

Reviewed: https://review.openstack.org/209404
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible/commit/?id=9ae6eeca8b592e345202c2fbf697ce2089718ac9
Submitter: Jenkins
Branch: master

commit 9ae6eeca8b592e345202c2fbf697ce2089718ac9
Author: Darren Birkett <email address hidden>
Date: Wed Aug 5 09:42:57 2015 +0100

    set unique galera server-id

    Each slave in a mysql replication cluster needs to have a unique
    'server-id' set. This is an arbitrary integer, and often people select
    1,2,3 etc. For easy deterministic uniqueness without needing to look at
    what you've already used, a simple filter has been created to allow for
    the hostname to be converted into an integer.

    The server ID variable has been added to the my.cnf.j2 template
    and the galera_server defaults/main.yml file. The generation of the
    server-id variable happens within the `galera-install.yml` play making
    it so there is no future impact in role requires.

    Change-Id: Id15149e59cb03ab268bb3b7eeaf391334dfc0c01
    Fixes-Bug: #1479484

Changed in openstack-ansible:
status: In Progress → Fix Committed
Revision history for this message
Bjoern (bjoern-t) wrote :

Personally I don't see the need for juno anymore, considering how long open this issue is already.
This issue needs to be fixed for kilo since major workload is and will run for quite some time.,

Revision history for this message
Jesse Pretorius (jesse-pretorius) wrote :
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to openstack-ansible (kilo)

Reviewed: https://review.openstack.org/267054
Committed: https://git.openstack.org/cgit/openstack/openstack-ansible/commit/?id=d0bb38042e1367d53d3fce206ed1d26bcbc9d432
Submitter: Jenkins
Branch: kilo

commit d0bb38042e1367d53d3fce206ed1d26bcbc9d432
Author: Darren Birkett <email address hidden>
Date: Wed Aug 5 09:42:57 2015 +0100

    set unique galera server-id

    Each slave in a mysql replication cluster needs to have a unique
    'server-id' set. This is an arbitrary integer, and often people select
    1,2,3 etc. For easy deterministic uniqueness without needing to look at
    what you've already used, a simple filter has been created to allow for
    the hostname to be converted into an integer.

    The server ID variable has been added to the my.cnf.j2 template
    and the galera_server defaults/main.yml file. The generation of the
    server-id variable happens within the `galera-install.yml` play making
    it so there is no future impact in role requires.

    Conflicts:
     playbooks/plugins/filters/osa-filters.py

    Change-Id: Id15149e59cb03ab268bb3b7eeaf391334dfc0c01
    Closes-Bug: #1479484
    (cherry picked from commit 9ae6eeca8b592e345202c2fbf697ce2089718ac9)

Revision history for this message
Jesse Pretorius (jesse-pretorius) wrote :

Setting Juno series target to "Won't Fix" as there will be no more adjustments going into the Juno branch unless they are Critical bugs.

Revision history for this message
Davanum Srinivas (DIMS) (dims-v) wrote : Fix included in openstack/openstack-ansible 11.2.11

This issue was fixed in the openstack/openstack-ansible 11.2.11 release.

Revision history for this message
Doug Hellmann (doug-hellmann) wrote : Fix included in openstack/openstack-ansible 11.2.12

This issue was fixed in the openstack/openstack-ansible 11.2.12 release.

Revision history for this message
Davanum Srinivas (DIMS) (dims-v) wrote : Fix included in openstack/openstack-ansible 11.2.14

This issue was fixed in the openstack/openstack-ansible 11.2.14 release.

Revision history for this message
Doug Hellmann (doug-hellmann) wrote : Fix included in openstack/openstack-ansible 11.2.15

This issue was fixed in the openstack/openstack-ansible 11.2.15 release.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers