Ubuntu 20.04 (Focal Fossa) support

Bug #1875544 reported by Jane Sandberg on 2020-04-28
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned
OpenSRF
Undecided
Unassigned

Bug Description

It was only released a few days ago, but I got excited! :-)

I was able to run through the basic installation using the bionic steps without much trouble. There are two python-related packages available in bionic that are no longer available for focal:

* python-memcache no longer is available, but python3-memcache is.
* python-pyxmpp's github refers to the project as "obsolete": https://github.com/Jajcus/pyxmpp It seems like there are a few other xmpp libraries for python included in the ubuntu repositories.

I know there is some relevant discussion happening over on bug 1827055.

I haven't done any testing other than adding numbers together using srfsh, so we should do more of that, too. :-)

Changed in evergreen:
assignee: nobody → Jason Stephenson (jstephenson)
Changed in opensrf:
assignee: nobody → Jason Stephenson (jstephenson)
Jason Stephenson (jstephenson) wrote :

I have a branch for OpenSRF:

https://git.evergreen-ils.org/?p=working/OpenSRF.git;a=shortlog;h=refs/heads/user/dyrcona/lp1875544-ubuntu-focal-fossa-support

and a branch for Evergreen:

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/dyrcona/lp1875544-ubuntu-focal-fossa-support

Both branches work to install OpenSRF and Evergreen, all tests pass, and basic functionality appears to work.

The Focal Fossa support is in the top commit of each branch. They both are built upon the branches from two other bugs, which should go in before the Focal Fossa support is added.

Bill's branches on bug 1827055 to remove Python from OpenSRF and Evergreen should be applied first. After that my branches to remove Java for OpenSRF and Evergreen from bug 1827051 should be applied.

My Java branches have been rebased on Bill's Python branches, and the Focal Fossa branches are based on the latter.

tags: added: pullrequest
Changed in evergreen:
assignee: Jason Stephenson (jstephenson) → nobody
Changed in opensrf:
assignee: Jason Stephenson (jstephenson) → nobody
Changed in evergreen:
milestone: none → 3.7-beta
Jason Stephenson (jstephenson) wrote :

I have force pushed a couple of changes to the Evergreen branch since I updated the bug this morning. These are changes to the server install and upgrade instructions that were missed.

Jason Stephenson (jstephenson) wrote :

I rebased the OpenSRF and Evergreen branches on master just now to keep up with the latest feedback fest additions. The updates have been forced pushed to the previous working branches.

Changed in evergreen:
status: New → Confirmed
Changed in opensrf:
status: New → Confirmed
Jason Stephenson (jstephenson) wrote :

I rebased the branches yet again, and tested them with a fresh install on a virtual machine. All tests pass, and the OPAC and staff client work.

Bill Erickson (berick) on 2021-02-22
Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
Bill Erickson (berick) wrote :
tags: added: signedoff
Changed in evergreen:
assignee: Bill Erickson (berick) → nobody
Ben Shum (bshum) wrote :

Pushed to master for Evergreen / OpenSRF.

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in opensrf:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers