Installation Support for Ubuntu 18.04 "Bionic Beaver"

Bug #1793585 reported by Jason Stephenson on 2018-09-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned
OpenSRF
Wishlist
Unassigned

Bug Description

The most recent long term support release of Ubuntu 18.04, Bionic Beaver, was released in April. We should provide installation support for this release since we generally aim to support Ubuntu LTS releases.

To that end, some of us in the community have been working on branches and finding other bugs (https://bugs.launchpad.net/opensrf/+bug/1793356) along the way.

This Lp bug will be solely for changes required to install OpenSRF and Evergreen on Ubuntu 18.04 and will mainly be aimed at README, configuration, and prerequisite installation.

Changed in evergreen:
importance: Undecided → Wishlist
Jason Stephenson (jstephenson) wrote :

Chris Sharp started a branch some months ago to get OpenSRF to install and work on Ubuntu 18.04. Ben Shum updated the README and squashed Chris's multiple commits into one. When combined with the branch from bug 1793356, one gets a working OpenSRF installation on Ubuntu 18.04.

I have added my signoff to the combined branch and posted it to collab/dyrcona/ubuntu-bionic-support

http://git.evergreen-ils.org/?p=working/OpenSRF.git;a=shortlog;h=refs/heads/collab/dyrcona/ubuntu-bionic-support

Jason Stephenson (jstephenson) wrote :

Testing changes for Ubuntu 18.04 and Evergreen indicates that many of the Perl warnings that we've been ignoring for years have come back to bite us. Both make check and make livecheck fail at least one test, the latter fails multiple. The failure of make check involves a warning that has become illegal in Perl 5.26. I suspect, but have not taken the time to investigate, that the live tests fail for similar reasons. I am calling it a day for now, but I will take this up again, later.

Jason Stephenson (jstephenson) wrote :

Benjamin Shum and I have a collab branch for adding Ubuntu 18.04 support to Evergreen. So far this looks like all that is needed:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/collab/dyrcona/ubuntu-bionic-support

All tests pass.

tags: added: pullrequest
Changed in evergreen:
status: New → Confirmed
Changed in opensrf:
status: New → Confirmed
Changed in evergreen:
milestone: none → 3.next
Galen Charlton (gmc) wrote :

Pushed the OpenSRF side of the branch to master for inclusion in OpenSRF 3.1-beta

Changed in opensrf:
milestone: none → 3.1-beta
status: Confirmed → Fix Committed
Jason Stephenson (jstephenson) wrote :

I just pushed a followup commit to reorder the ejabberd configuration steps to follow the order that the settings appear in the ejabberd.yml file.

Ben Shum (bshum) wrote :

Pushed some additional changes to Dyrcona's collab branch for Bionic support:

- add PG community repo setup for standalone PG target
- point at MARC::File::XML instead of MARC::XML (old and no longer supported)

Jason Stephenson (jstephenson) wrote :

Branch has been rebased, signed off by Ben and myself, and all tests pass on Ubuntu 18.04.

It could use another pair of eyes and more testing on Ubuntu 16.04 and Debian releases.

tags: added: signedoff
Jane Sandberg (sandbej) wrote :

Thanks for your work on this, all. I know that you added documentation to the README. Could you please also add a quick release note?

tags: added: needsreleasenote
Jason Stephenson (jstephenson) wrote :

I will rebase the branch, test it again on Ubuntu 18.04 and 16.04, and add a release note.

I want to mention that bug 1801163 also needs to be fixed for Ubuntu 18.04.

Changed in evergreen:
assignee: nobody → Jason Stephenson (jstephenson)
Jason Stephenson (jstephenson) wrote :

I added release notes, rebased, and retested the branch on both Ubuntu 18.04 and Ubuntu 16.04. All tests pass. I have force pushed to same branch as mentioned in comment #3.

I want to note that the Postgres, pgtap, live tests appear to interfere with the Perl live tests. Running one before the other causes whichever is run second to fail. I have not tested this with a regular master branch, but I do seem to recall having that happen without this branch applied.

Changed in evergreen:
assignee: Jason Stephenson (jstephenson) → nobody
tags: removed: needsreleasenote
Changed in evergreen:
milestone: 3.next → 3.3-beta1
Jason Stephenson (jstephenson) wrote :

I want to add that I am unable to reproduce the test failure from comment 10 on Ubuntu 16.04 with both this branch and the PostgreSQL 10 branch from bug 1730726 installed.

Ben Shum (bshum) wrote :

Pushed to Evergreen master.

Changed in evergreen:
status: Confirmed → Fix Committed
Galen Charlton (gmc) on 2019-01-10
Changed in opensrf:
status: Fix Committed → Fix Released
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers