Upgrading to OpenSRF 2.5.1 appears to break XUL 2.12.5

Bug #1717350 reported by Jason Stephenson
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenSRF
High
Unassigned

Bug Description

OpenSRF version 2.5.1
Evergreen version 2.12.5
PostgreSQL version 9.5.9
O/S version Ubuntu 16.04.3

SITKA reported issues with Evergreen 2.12 after upgrading to OpenSRF 2.5.1 in IRC:

http://irc.evergreen-ils.org/evergreen/2017-09-14#i_324068

I upgraded a test VM that already had OpenSRF 2.5.0 and Evergreen 2.12.5 installed. I only upgraded OpenSRF 2.5.1.

I logged in with the XUL Staff client and everything seemed to be working until I quit the client, deleted ws_info, and tried to register a new workstation.

I received the following error message in the XUL client:

Network or server failure. Please check your Internet connection to jasontest.cwmars.org and choose Retry Network. If you need to enter Offline Mode, choose Ignore Errors in this and subsequent dialogs. If you believe this error is due to a bug in Evergreen and not network problems, please contact your help desk or friendly Evergreen administrators, and give them this information:
method=open-ils.actor.org_tree.descendants.retrieve
params=[1,0]
THROWN:
{"payload":[],"debug":"osrfMethodException : *** Call to [open-ils.actor.org_tree.descendants.retrieve] failed for session [1505417225.818009.150541722512195], thread trace [1]:\n, or ] expected while parsing array, at character offset 31100 (before \"\"1\",\"1\"]},{\"__c\":\"ao...\") at /usr/local/share/perl/5.22.1/OpenSRF/Utils/JSON.pm line 109.\n\n","status":500}
STATUS:

This behavior is consistent, even after running autogen.sh, stopping and restarting services, even remaking and reinstalling Evergreen 2.12.5.

I will attach relevant logs (osrfsys.log, gateway.log, and open-isl.actor_stderr.log for the session. I plan to try again tomorrow with a fresh install of OpenSRF 2.5.1 and Evergreen 2.12.5.

Revision history for this message
Jason Stephenson (jstephenson) wrote :
Revision history for this message
Jason Stephenson (jstephenson) wrote :
Revision history for this message
Jason Stephenson (jstephenson) wrote :
Galen Charlton (gmc)
no longer affects: evergreen
Changed in opensrf:
importance: Undecided → High
status: New → Confirmed
milestone: none → 2.5.2
assignee: nobody → Galen Charlton (gmc)
Revision history for this message
Galen Charlton (gmc) wrote :

A patch is available in the user/gmcharlt/lp1717350_fractional_characters_are_not_a_thing branch:

http://git.evergreen-ils.org/?p=working/OpenSRF.git;a=shortlog;h=refs/heads/user/gmcharlt/lp1717350_fractional_characters_are_not_a_thing

tags: added: pullrequest
Changed in opensrf:
assignee: Galen Charlton (gmc) → nobody
Revision history for this message
Jason Stephenson (jstephenson) wrote :

Works for me. Fixes the register workstation issues and the open-ils.storage.actor.org_unit.descendants.atomic calls in Evergreen.

I've signed off and pushed to master and rel_2_5 for chunks everywhere.

Changed in opensrf:
assignee: nobody → Jason Stephenson (jstephenson)
Changed in opensrf:
assignee: Jason Stephenson (jstephenson) → nobody
status: Confirmed → Fix Committed
Galen Charlton (gmc)
Changed in opensrf:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers