opensrf-2-x.tar.gz contains invalid URL to java library

Bug #1366933 reported by Lucien van Wouw on 2014-09-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenSRF
Undecided
Unassigned

Bug Description

The OpenSRF tar ball distributions refer to an invalid url to obtain the memcache library:
http://evergreen-ils.org/downloads/opensrf-2.3.0.tar.gz
http://evergreen-ils.org/downloads/previews/opensrf-2.4.0-alpha.tar.gz

See:
../src/java/opts.sh
will resolve to
http://img.whalin.com/memcached/jdk6/standard/java_memcached-release_2.0.1.jar (404)

Hence a make with the --enable-java option will fail.

It may be better to build from the code base:
https://github.com/gwhalin/Memcached-Java-Client/tree/release_2.0.1

Or update to a more recent version with a maven artifact from
http://mvnrepository.com/artifact/com.whalin/Memcached-Java-Client

Ben Shum (bshum) wrote :

Changing this to affect the OpenSRF project since it more directly applies to that.

I haven't built OpenSRF with java lately, but basically assumed that it's been broken for awhile. Perhaps we should remove that flag from the instructions until this is repaired?

affects: evergreen → opensrf
Lucien van Wouw (lvwouw) wrote :

I think that is better for now.

To try out a client I mavenized one here:
https://github.com/IISH/opensrf-java-client

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers