Settings wIndow does not open (and images can not be dropped on the timeline) for non-English languages

Bug #923873 reported by Maan on 2012-01-30
46
This bug affects 7 people
Affects Status Importance Assigned to Milestone
OpenShot Video Editor
Critical
Unassigned

Bug Description

I just install new version of openshot (1.4.1), and "setting" window does not open !!!

Related branches

Andy Finch (fincha) wrote :

What locale setting do you use?

lw4z (ivanvalentimsantos) wrote :

pt-br

Jonathan Thomas (jonoomph) wrote :

Thanks for reporting this bug. This is now fixed in the trunk.

Changed in openshot:
milestone: none → 1.4.2
importance: Undecided → Critical
status: New → Fix Committed
Maan (amaro-manu) wrote :
Download full text (3.8 KiB)

thank you for your answers.

I try to reinstall openshot 1.4.1 and now he does not want to open !!!!

I'm using using Ubuntu 11.04 - the Natty Narwhal, and this is what the terminal me Raport

maan@maan-desktop:~$ openshot

------------------------- ERROR 1 ------------------------------
Failed to import 'from openshot import main'
Error Message: cannot import name main
----------------------------------------------------------------
--------------------------------
   OpenShot (version 1.4.1)
--------------------------------
Process no longer exists: 8956. Creating new pid lock file.
on_mnuHistory_toggled called with self.GtkCheckMenuItem
on_nbFiles_switch_page
on_nbFiles_switch_page

Detecting formats, codecs, and filters...
---
video_codecs:
  - asv1
  - asv2
  - bmp
  - dnxhd
  - dvvideo
  - ffv1
  - ffvhuff
  - flashsv
  - flv
  - gif
  - h261
  - h263
  - h263p
  - huffyuv
  - jpegls
  - ljpeg
  - mjpeg
  - mpeg1video
  - mpeg2video
  - mpeg4
  - msmpeg4v1
  - msmpeg4v2
  - msmpeg4
  - pam
  - pbm
  - pcx
  - pgm
  - pgmyuv
  - png
  - ppm
  - qtrle
  - rawvideo
  - roqvideo
  - rv10
  - rv20
  - sgi
  - snow
  - svq1
  - targa
  - tiff
  - v210
  - wmv1
  - wmv2
  - zlib
  - zmbv
  - libdirac
  - libschroedinger
  - libtheora
  - libvpx
  - libx264
  - libxvid
...
---
audio_codecs:
  - aac
  - ac3
  - alac
  - flac
  - mp2
  - nellymoser
  - sonic
  - sonicls
  - wmav1
  - wmav2
  - pcm_alaw
  - pcm_f32be
  - pcm_f32le
  - pcm_f64be
  - pcm_f64le
  - pcm_mulaw
  - pcm_s8
  - pcm_s16be
  - pcm_s16le
  - pcm_s24be
  - pcm_s24daud
  - pcm_s24le
  - pcm_s32be
  - pcm_s32le
  - pcm_u8
  - pcm_u16be
  - pcm_u16le
  - pcm_u24be
  - pcm_u24le
  - pcm_u32be
  - pcm_u32le
  - pcm_zork
  - roq_dpcm
  - adpcm_adx
  - g726
  - adpcm_ima_qt
  - adpcm_ima_wav
  - adpcm_ms
  - adpcm_swf
  - adpcm_yamaha
  - libgsm
  - libgsm_ms
  - libmp3lame
  - libvorbis
...
---
formats:
  - ac3
  - adts
  - aiff
  - amr
  - asf
  - ass
  - asf_stream
  - au
  - avi
  - avm2
  - crc
  - daud
  - dirac
  - dnxhd
  - dts
  - dv
  - eac3
  - ffm
  - filmstrip
  - flac
  - flv
  - framecrc
  - gif
  - gxf
  - h261
  - h263
  - h264
  - image2
  - image2pipe
  - ipod
  - m4v
  - matroska
  - matroska
  - mjpeg
  - mlp
  - mmf
  - mov
  - mp2
  - mp3
  - mp4
  - mpeg
  - vcd
  - mpeg1video
  - dvd
  - svcd
  - mpeg2video
  - vob
  - mpegts
  - mpjpeg
  - mxf
  - mxf_d10
  - null
  - nut
  - ogg
  - alaw
  - mulaw
  - f64be
  - f64le
  - f32be
  - f32le
  - s32be
  - s32le
  - s24be
  - s24le
  - s16be
  - s16le
  - s8
  - u32be
  - u32le
  - u24be
  - u24le
  - u16be
  - u16le
  - u8
  - psp
  - rawvideo
  - rm
  - RoQ
  - rtp
  - rtsp
  - sox
  - spdif
  - swf
  - 3g2
  - 3gp
  - truehd
  - rcv
  - voc
  - wav
  - webm
  - yuv4mpegpipe
  - alsa
  - oss
...

------------------------- ERROR 2 ------------------------------
Failed to import 'from openshot.openshot import main'
Error Message: 'NoneType' object has no attribute 'xid'
----------------------------------------------------------------

OpenShot has failed to import some of the Python files or libraries
required for our application to run. Here are some trouble shooting
tips:

Tip 1) Check if MLT can be succes...

Read more...

Jonathan Thomas (jonoomph) wrote :

Maan,
It seems this is a different bug (object has no attribute 'xid'). The original bug (settings window not opening in non-English locales) has been fixed. Let's open a different bug report for this.

Olivier Girard (eolinwen) wrote :

Hi Maan
For having the last version (with the fix) you must pass by the daily ppa.
See here how to do this operation : https://answers.launchpad.net/openshot/+faq/1850
Think to desactivate the "official" before using the second.

Maan (amaro-manu) wrote :

Thank you very much for your help,
Jonathan excuse me, I am rather user forum and not sites "bug report" :-)

Especially, I think my last problem is come from my setup :-(

Thank and good luck for openshot.

summary: - openshot 1.4.1 "setting"window , does not open
+ Settings wIndow does not open for non-English languages
summary: - Settings wIndow does not open for non-English languages
+ Settings wIndow does not open (and images can not be dropped on the
+ timeline) for non-English languages
Andy Finch (fincha) on 2012-02-06
Changed in openshot:
status: Fix Committed → Fix Released
Jonathan Thomas (jonoomph) wrote :

Just a comment for anyone still getting an error trying to drop an image on the timeline. To fix your settings file (which might have been messed up from version 1.4.1), just open up the Preferences window, and then close it. That will update your settings file with the correctly formatted "Default Image Length" setting, and now images can be successfully dropped on your timeline. Good luck!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers